Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It randomly stops working as I'm working off a laptop, I click the option "Auto Ethernet" but it won't connect to the network again, I have to restart my laptop and then everything works fine but the connection eventually drops. I think it was after some update that I did, I am using 11.10.

share|improve this question

closed as too localized by fossfreedom Jan 3 '13 at 22:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you try with a different cable ? –  marc-andre benoit Apr 2 '12 at 1:45
    
Yeah... I tried with a different one but the same thing keeps happening. One thing that I did notice is that it is losing its connection when I use lots of bandwidth (Torrents for example). –  César Bastidas Apr 2 '12 at 18:35
    
Many ISPs actively filter and monitor connections consuming a large amount of bandwidth. I specifically remember an instance where a sudden spike in bandwidth consumption would end up in your connection being throttled immediately. It is likely that this is what is happening to you and that you're either being throttled down next to nothing or just disconnected from the router. –  RWC Apr 3 '12 at 5:01
    
does this happen when you're running from the battery only ? or also when connected to a power source ? i ask because sometimes ethernet cards tend to have powersaving modes while on battery.. also.. do you have a possibility to use another ethernet card either a usb<->ethernet card .. or a cardbus/pcmcia interface card ? just to rule out the possibility of a hardware malfunction..(or misconfiguration..) but i have to agree with Hobie .. bandwidth throtling from your ISP is very likely.. –  marc-andre benoit Apr 3 '12 at 8:11
    
Well I just switched from ethernet to usb interface, let's see what happens. But I know is not an ISP filtering, been using this for years now and when I use my desktop it does work. I'll let you know how USB connection is working so far. Thanks for your help (As you can see, english is not my main language, I'm sorry for any troubles you've had when reading my comments) –  César Bastidas Apr 3 '12 at 17:51
show 1 more comment

1 Answer 1

This is due to a DHCP lease time with a router/DHCP router. Check this file and see what the renewal times are.

 vi /var/lib/dhcp/dhclient.leases

A lease looks like this.

lease {
  interface "eth0";
  fixed-address 192.168.1.107;
  option subnet-mask 255.255.255.0;
  option dhcp-lease-time 86400;
  option routers 192.168.1.1;
  option dhcp-message-type 5;
  option dhcp-server-identifier 192.168.1.1;
  option domain-name-servers 208.67.222.222,208.67.220.220,8.8.8.8,4.2.2.2,68.94.156.1;
  option dhcp-renewal-time 43200;
  option dhcp-rebinding-time 75600;
  option host-name "bust0ut5";
  renew 0 2012/03/04 00:29:06;
  rebind 0 2012/03/04 10:44:45;
  expire 0 2012/03/04 13:44:45;
}

If the times are too short than you will need to configure your DHCP server. If you are on a public network E.g. Starbucks, than your answer lies therein.

share|improve this answer
    
Ok, I did check those lines but it seems that it's missing some lines, the ones that you wanted me to check... –  César Bastidas Apr 2 '12 at 18:39
    
could you perhaps paste those in a comment to give us some clues as to what is there or not ?.. is the lease{ ...} part missing entirely ? –  marc-andre benoit Apr 3 '12 at 8:06
    
lease { interface "eth0"; fixed-address 201.210.178.55; option subnet-mask 255.255.224.0; option dhcp-lease-time 28800; option routers 201.210.160.1; option dhcp-message-type 5; option dhcp-server-identifier 200.109.126.43; option domain-name-servers 200.44.32.12,200.11.248.12; option interface-mtu 576; option broadcast-address 201.210.191.255; option host-name "c9d2b237-dslam-172-17-161-241-304-297-mbo-bras-02"; option domain-name "cantv.net"; renew 1 2012/04/02 07:52:53; rebind 1 2012/04/02 11:15:50; expire 1 2012/04/02 12:15:50; } –  César Bastidas Apr 3 '12 at 17:43
    
I'm sorry, I don't know how to paste codes like you did. –  César Bastidas Apr 3 '12 at 17:53
    
I suggest you open terminal from the launcher, then type sudo gedit /var/lib/dhcp/dhclient.leases. Check the line with dhcp-lease-time. The value in the previous comment looks good. –  hexafraction May 8 '12 at 19:22
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.