Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are other questions on this but none have been taken very far in their analysis.

I get disconnects very often - sometimes every 20 mins or so, but sometimes even every few minutes.

The way I have been getting around it is to disconnect from the Wifi connection and reconnect - and then it works fine again until the next disconnect.

I am running Ubuntu 11.04 on an ASUS A52F. Can anyone help me please?

EDIT: My investigations have led me to believe this might be the router, as the same problem is duplicated on my gf's HTC smartphone. Any ideas of how to solve?

Output of lspci | grep -i net

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01) 04:00.5 
Ethernet controller: JMicron Technology Corp. 
JMC250 PCI Express Gigabit Ethernet Controller (rev 03)
share|improve this question
    
What Chipset? lspci | grep -i net –  user unknown Apr 1 '12 at 23:48
    
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01) 04:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller (rev 03) –  Benett Freeman Apr 4 '12 at 11:16

3 Answers 3

Try this command,

sudo dhclient -v

There shouldn't be any errors. My successful output looks like this,

Listening on LPF/eth3/00:e0:52:ce:a0:f6
Sending on   LPF/eth3/00:e0:52:ce:a0:f6
Listening on LPF/eth2/00:50:43:00:f5:c7
Sending on   LPF/eth2/00:50:43:00:f5:c7
Listening on LPF/eth0/20:cf:30:4f:60:43
Sending on   LPF/eth0/20:cf:30:4f:60:43
Sending on   Socket/fallback
DHCPDISCOVER on eth3 to 255.255.255.255 port 67 interval 3
DHCPREQUEST of 192.168.11.100 on eth2 to 255.255.255.255 port 67
DHCPREQUEST of 192.168.1.107 on eth0 to 255.255.255.255 port 67
DHCPACK of 192.168.1.107 from 192.168.1.1
RTNETLINK answers: File exists
bound to 192.168.1.107 -- renewal in 40407 seconds.
share|improve this answer
    
Internet Systems Consortium DHCP Client 4.1.1-P1 Copyright 2004-2010 Internet Systems Consortium. All rights reserved. For info, please visit isc.org/software/dhcp Listening on LPF/wlan0/74:f0:6d:7c:11:42 Sending on LPF/wlan0/74:f0:6d:7c:11:42 Sending on Socket/fallback DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3 DHCPOFFER of 192.168.0.11 from 192.168.0.1 DHCPREQUEST of 192.168.0.11 on wlan0 to 255.255.255.255 port 67 DHCPACK of 192.168.0.11 from 192.168.0.1 bound to 192.168.0.11 -- renewal in 1767 seconds. –  Benett Freeman Apr 4 '12 at 11:17

Try this:

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

sudo modprobe -rfv ath9k
sudo modprobe -v ath9k`

And make sure that your router is set on WPA2 encryption.

share|improve this answer

This is due to a DHCP lease time with a router/DHCP router. Check this file and see what the renewal times are.

 vi /var/lib/dhcp/dhclient.leases

A lease looks like this.

lease {
  interface "eth0";
  fixed-address 192.168.1.107;
  option subnet-mask 255.255.255.0;
  option dhcp-lease-time 86400;
  option routers 192.168.1.1;
  option dhcp-message-type 5;
  option dhcp-server-identifier 192.168.1.1;
  option domain-name-servers 208.67.222.222,208.67.220.220,8.8.8.8,4.2.2.2,68.94.156.1;
  option dhcp-renewal-time 43200;
  option dhcp-rebinding-time 75600;
  option host-name "bust0ut5";
  renew 0 2012/03/04 00:29:06;
  rebind 0 2012/03/04 10:44:45;
  expire 0 2012/03/04 13:44:45;
}
share|improve this answer
    
My dhclient.leases file is empty! :( –  drN Apr 2 '12 at 0:48
    
lease { interface "wlan0"; fixed-address 192.168.0.11; option subnet-mask 255.255.255.0; option time-offset 0; option dhcp-lease-time 3600; option routers 192.168.0.1; option dhcp-message-type 5; option domain-name-servers 194.168.4.100,194.168.8.100; option dhcp-server-identifier 192.168.0.1; option default-ip-ttl 64; renew 3 2012/04/04 11:45:55; rebind 3 2012/04/04 12:08:58; expire 3 2012/04/04 12:16:28; –  Benett Freeman Apr 4 '12 at 11:18
    
My investigations have led me to believe this might be the router, as the same problem is duplicated on my gf's HTC smartphone. Any ideas of how to solve? –  Benett Freeman Apr 5 '12 at 12:04
    
If you can access the router, change the lease time to 36000. We had the same problem in the dormitory, so I changed the leasetime for the smart phones to 24h. (We separate normal pc/laptop from smart phones) –  gajdipajti Apr 5 '12 at 12:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.