Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Dual core AMD E450 APU. When i tried to run a 64-bit OS that requires hardware virtualization using virtual-box it showed me an error "AMD-V is not enable".

My AMD processor should provide AMD-V support. And i can find no option for AMD-V in BIOS.

How can i solve this problem? How could i enable AMD-V for my APU?

Thanks in advance

lscpu :-

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             AuthenticAMD
CPU family:            20
Model:                 2
Stepping:              0
CPU MHz:               1650.000
BogoMIPS:              3291.72
Virtualization:        AMD-V
L1d cache:             32K
L1i cache:             32K
L2 cache:              512K
NUMA node0 CPU(s):     0,1

EDITED:-

Error of virtualBOX:-

Failed to open a session for the virtual machine XXX.

AMD-V is disabled in the BIOS. (VERR_SVM_DISABLED).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}
share|improve this question
    
If there really isn't any option related to virtualisation in your BIOS, then your only option may be to contact the BIOS vendor and ask if they can add one. Once the CPU feature has been disabled in this way, it can't be re-enabled without rebooting (at which point, the BIOS code disabling the feature will run again). –  James Henstridge Apr 2 '12 at 0:08
    
correct answer is already on both answers below... –  H_7 Apr 2 '12 at 1:15
    
@JamesHenstridge - I have encountered BIOS that had HW Virt disabled, but vendors I'm willing to buy from have ceased or lessened this practice. HP, for example, has gotten much better about this in recent years. –  hbdgaf Apr 2 '12 at 2:37
    
Bios default is disabled in Hp notebook running E450 CPU. Installing took over 4 hours and cursor movement etc. was very slow but enabling in bios did the trick, Ubuntu runs on Win7 ok. –  user76810 Jul 13 '12 at 16:12
    
try decreaseing the memory allocated for your virtual machine. –  user295105 Jun 19 at 21:28

3 Answers 3

up vote 5 down vote accepted

First enable AMD-V in the BIOS. It depends on your BIOS, but it'll look something like this (probably):

enter image description here

In virtualbox click ->Setting->System->Acceleration and enable the checkboxes as below.

enter image description here

share|improve this answer
1  
i said before, i don't have any option for virtualization in BIOS but my processor support virtualization. –  shantanu Apr 2 '12 at 3:40
1  
then you need to buy new hardware or try the second half of the answer –  hbdgaf Apr 2 '12 at 3:45

I have and AMD processor and installed Win8 64 bit in virtual box on a Win 7 32 bit system. Went into Bios and found virtualization and enabled it. That was all it needed.

share|improve this answer

I had run into the very same problem and after spending like 2hrs I finally solved this. I am on a 32bit sys and my Bios does not have this Vizualization Technology option.

The problem happened to be VirtualBox related, I did this:

VirtualBox > System > Processor > change the number of processors from 2 to 1

Worked for me.

share|improve this answer
    
This works for me too. I have the virtualization enabled in BIOS, but I had 3 processors enabled in VBox. –  Nicolás Nov 24 '13 at 22:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.