Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here I ask this question since 12.04 Beta 2 is usable and this question would come up sooner then later. After issuing the standard

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn
sudo apt-get update

I get the following errors.

W: Failed to fetch  404  Not Found        
W: Failed to fetch  404  Not Found    
W: Failed to fetch  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Is there any way to get around this. Excluding compiling from source as it usually introduces even more multilevel errors.

share|improve this question
Wait for stable release of Gimp2.7 and 12.04 – twister_void Apr 1 '12 at 17:03
Would I ask the question in the first place if this was an option? Besides, 2.7 will never be stable. – Bucic Apr 1 '12 at 17:10
That PPA has no packages for 12.04, that is why its failing. Maybe follow @Gaurav_Java advice or use 11.10? There is not much you can do except build from source code. Is that an option? – Bruno Pereira Apr 1 '12 at 17:23
@Bruno Pereira It is now :) Should I follow the popular instructions on the task and come back with errors or should I take some specific approach? – Bucic Apr 1 '12 at 17:25
From what I see online there are many people braking their systems trying to sort this out. Its hard when everything is beta or under development. – Bruno Pereira Apr 1 '12 at 17:31

If you cannot wait, according to this: you should download and install from source:

share|improve this answer
intltool > BABL > GLIB > GEGL > ... I've managed to install intltool and BABL but I'm stuck at building GEGL. It seems I've installed GLIB incorrectly. 'Entering directory, leaving directory, nothing to be done for `install-exec-am'' were the last returns after sudo make install for GLIB. Were they errors? – Bucic Apr 1 '12 at 19:34
up vote 3 down vote accepted

The simple answer is - install the stable 2.8 instead! Fortunatelly it also made gimp plugin registry (with the famous save for web plugin) easy to install.

Via :

GIMP 2.8 stable installation

If you're upgrading from an older GIMP version please visit the link and pay attention to the 'dist-upgrade' command (also if you want to revert to GIMP 2.6.x)

If you're just installing GIMP for the first time on your current system install:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

GIMP Plugin Registry for GIMP 2.8 installation

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp-plugin-registry
share|improve this answer
I get this when following Bucic's answer: gimp : Depends: libgimp2.0 (<= 2.6.12-z) but 2.8.0~rc1-0precise0~ppa is to be installed Depends: gimp-data (<= 2.6.12-z) but 2.8.0~rc1-0precise0~ppa is to be installed E: Unable to correct problems, you have held broken packages – rrohde Apr 14 '12 at 21:40
@rrohde Was it on clean 12.04 beta 2? If not - what actions did you do before this attempt? – Bucic Apr 15 '12 at 10:00

Looking at that PPA's website on launchpad...packages are not available for Precise yet. If you insist on installing Gimp 2.7 using that PPA (and you can, it may be messy but it is reversible), you could edit that repository in your software sources to point to oneiric instead of precise (just change the codename in Distribution). You do risk encountering some dependency issues (in which case I'd recommend removing the PPA and not continuing with the install). This is generally safe to do with a handful of repositories such as GetDeb, PlayDeb and Oracle VirtualBox, but Gimp does have a few more dependencies in the official repositories, so although this is highly discouraged, you can do it at your own risk and there's a good chance you won't have any issues with it.

share|improve this answer
How do I change the codename from oneiric to precise? My /etc/apt/sources.list file does not contain the gimp repo while /etc/apt/sources.list.d/matthaeus123-mrw-gimp-svn-precise.list does not include word "oneiric". It's all precise. – Bucic Apr 2 '12 at 15:54
Software Sources > Other Software > [PPA you want to edit], once selected hit the edit button, and modify the Distribution field. Change precise to oneiric. Ok, close. Then reload either graphically or via sudo apt-get update. – titaniumtux Apr 2 '12 at 16:50
For some reason software sources application is not being displayed in Unity Dash so I had to use gksudo software-properties-gtk to launch it. The problem is the modified distribution field won't retain 'oneiric'. It reverts to 'precise'. – Bucic Apr 2 '12 at 17:00
You can add it back to the Unity Dash by enabling it in the "Menu Editor" (make sure alacarte is installed, then run you're free to launch Software Sources from Dash). Alternatively it can be accessed from the menus in Software Center and Synaptic. You should be able to set the PPA to oneiric. Worst case scenario, you can manually download the binaries from the PPA on Launchpad. You wouldn't get automatic updates without the PPA, but hey at least you'll have something to keep you busy until Ubuntu 12.04 is released, and then you add the PPA again. – titaniumtux Apr 3 '12 at 2:43

The ppa's 2.7.5 would be fine in 12.04 if the source entries where edited as in the answer by titaniumtux, other than the fact one package is broken

The reason the current builds won't work is because there was an error in the libgimp control file that created an unsatisfiable dependency in the deb package. Once the error is corrected the ppa will be fine & likely would also get precise packages.

I did email the ppa owner almost a month ago, so far no re-builds

You can actually still use the ppa if desired, you'd only have to download the libgimp2.0_ package and thru various means 'unpack' it, fix the control file, re-package & install. Then gimp, ect. would install fine

If inclined then ask another question on how to do if you don't know.

For reference the 'bad' entry in the .deb's control is highlighted below, there is no libglib2.0, the correct name for the package is also in the depends - libglib2.0-0

Depends: libc6 (>= 2.11), libcairo2 (>= 1.2.4), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.30.2), libgtk2.0-0 (>= 2.24.0), libpango1.0-0 (>= 1.22.0), libglib2.0 (>= 2.30.2)

share|improve this answer

Follow up on dougs answer - here's how I did it (warning, this might mess up your system and perhaps your life as well):

Install the oneiric ppa as described in the other answers.

In the following, replace xxx with your architecture.

Go to;O=D and download libgimp and gimp debs for your architecture.

Extract the debs: right-click in nautilus, select "Extract here". It will create a nice subdir for you with the same name as the deb-file.

In libgimp:

Edit DEBIAN/control and remove , libglib2.0 (>= 2.30.2) from the Depends: section. You'll see libglib is listed twice. We wan't to get rid of the last one. Save the file.

Now we want to create a new deb file with our change applied: Open a terminal and cd to the path where you downloaded and extracted the deb files. Run

dpkg-deb --build libgimp2.0_2.7.5-2012020902~oo_xxx/

then install the deb: sudo dpkg -i libgimp2.0_2.7.5-2012020902~oo_xxx.deb

Next we install gimp-data from the ppa: sudo apt-get install gimp-data

The gimp-package depends on a version of libpoppler that has been updated with Ubuntu 12.04. We will now brutally change the dependency. I do not know what the consequences of this will be. If the api has changed pdf-handling probably won't work.

In the terminal cd into the dir where the gimp deb was extracted to. Again edit the control file. This time, change libpoppler-glib6 to libpoppler-glib8 (>= 0.18). Save the file and rebuild and install the deb as you did with libgimp.

share|improve this answer
The most helpful answer so far! But I encountered errors during installation of the modified gimp deb. <code> gimp depends on gimp-data (>= 2.7.5); however: Version of gimp-data on system is 2.6.12-1ubuntu1. gimp depends on libbabl-0.0-0 (>= 0.1.3); however: Package libbabl-0.0-0 is not installed. gimp depends on libgegl-0.0-0 (>= 0.1.3-2); however: Package libgegl-0.0-0 is not installed. gimp depends on libjpeg62 (>= 6b1); however: Package libjpeg62 is not installed.<code> – Bucic Apr 4 '12 at 18:21
@Bucic: Remember to add deb oneiric main to sources.list – Thomsen Apr 10 '12 at 18:44
The PPA was added at the time of accomplishing the procedure. sudo apt-get update had also been issued before I started the procedure. Couldn't you just prepare a script if you're savvy enough? I've seen such a script for 2.7.5 somewhere. Maybe you could just modify it. / BTW GIMP 2.8 RC1 has been released. – Bucic Apr 11 '12 at 7:24
Seems to be the thing we need I haven't tested it yet. – Bucic Apr 11 '12 at 9:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.