Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a huawei ec1561 broadband data card, ISP-MTS India. I am not able to connect internet through it. while connecting it via network manager it says "You are registered with home network" and again "Modem network disconnected" . i think it is detected as a modem but not connecting properly. Any help please? I'm hitting this rock with my head more than a month...

when I tried installing the driver that came with the device it finally says "Installing NDIS driver failed". I can post further information if anybody helps

share|improve this question

1 Answer 1

up vote 1 down vote accepted
  1. Right click in network manager
  2. click on "edit connections" then go to mobile broadband
  3. Select existing connection, click on Edit
  4. Now goto mobile broadband tab. Provide user name [user name is - internet@internet.mtsindia.in ] and password [password is - mts] if not given already.
  5. Now try to connect, if same problem ouccures try the following
  6. Next go to "PPP settings tab" , in authentication click in "configure methods". Check only "CHAPS"
  7. Compression: Be sure the following are ticked: Allow BSD data compression, Allow Deflate data compression and Use TCP header compression

If the above settings doesn't work, try with other authentication method.

Alternatively you can use wvdial. Please comment here if the above method doesn't work. Accept this as an answer if it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.