Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using ubuntu 10.10 and until about 3 days ago rhythmbox worked fine but now when I start it, it opens, then after 4 second it crashes.
When running it from terminal I get this:

>    ~$ rhythmbox  
(rhythmbox:27420): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
** Message: pygobject_register_sinkfunc is deprecated (GstObject)

>    (rhythmbox:27420): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed  
    Segmentation fault

and then rhythmbox closes.
What to do?

Edit: Disabled most of the plugins and it's not crashing now, but i still get this when running from terminal:

>(rhythmbox:27420): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed ** Message: pygobject_register_sinkfunc is deprecated (GstObject)

>(rhythmbox:27420): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

Should I worry?

share|improve this question
I'm having the same issue but noticed that if the device that my music is stored on is not mounted, Rhythmbox launches normally. Once I mount my music, it's detected then listed in my library and I can use Rhythmbox again. My best guess is that my library got to a certain size that cannot be handled at launch-time. To test this, you could hide/move everything that is in your library then slowly re-introduce it to see at what point this error occurs. – Alastair Jan 3 '13 at 10:13
up vote 4 down vote accepted

Still no solutions except to remove ubuntu one music store plugin.

Even connecting to ubuntu one then laucnhing rhythmbox solved nothing.

Then i tried to purge all local rhythmbox data so it would start fresh still crashes on launch

  1. Remove ubuntu one music store plugin from synaptic
  2. Delete/clear all local rhythmbox references with

    rm ~/.local/share/rhythmbox/ ~/.cache/rhythmbox/ ~/.gconf/apps/rhythmbox/ -r

  3. Launch Rhythmbox and disable all music store/fm rhythmbox plugins, then quit rhythmbox

  4. Reinstall ubuntuone music store plugin
  5. Launch Rhythmbox again and now it shouldnt crash, renable all the plugins you disabled

or you can try this also Try disabling or uninstalling.

To disable run this in terminal


navigate to apps - rhythmbox - plugins - umusicstore and disable (uncheck enter image description here

Or search rhythmbox in synaptic and remove the plugin (rhythmbox-ubuntuone-music-store)

share|improve this answer
I already removed the ubuntuone plugin with sudo apt-get remove rhythmbox-ubuntuone-music-store and it changed nothing. – Kristal Apr 1 '12 at 11:10
@Kristal did you follow all the steps which i told u – twister_void Apr 1 '12 at 11:18
I disabled most of the plugins (radio stations and more) and now it works fine, not crashing. But I still get those errors when opening it from terminal just without the 'Segmentation fault' – Kristal Apr 1 '12 at 11:21
@Kristal Now also u are facing any error – twister_void Apr 1 '12 at 11:37
@Gaurav_Java be careful with what you copy from the forums and how you present that data. – Bruno Pereira Apr 1 '12 at 18:34

First thing I would recommend, is to upgrade to Ubuntu 11.04 at least. Ubuntu 10.10 will reach End Of Life in a few weeks, when 12.04 is released (which I'd really recommend upgrading to).

The crash likely had nothing to do with Ubuntu One, but it's impossible to know that as you asked a question here, instead of reporting the bug. If things crash, please report bugs, rather than asking questions on askUbuntu (which is not a bug reporting forum).

share|improve this answer

Well in my case I have music stored on a network share. I deleted some files from the library on another computer. When i started up Rhythmbox it still showed these songs for a couple of seconds and then vanishes. And so does Rhythmbox.

So I deleted ~/.local/share/rhythmbox and it started up without a hitch. It just needed to re-index the location where the music is stored.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.