Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As a playlist or internet radio station plays, a notification pops up in the top right corner every time the song changes.

I can't find any way either within Banshee or settings in general to stop this.

How do I stop Banshee from putting a notification in the panel for every song?

Further, can I stop Banshee from outputting any notifications at all?

Update: I tried going into Banshee → Edit → Preferences → Extensions, and disabled the Sound Menu Integration, but this does not seem to stop notifications.

share|improve this question
    
Does this Q&A resolve this? if so, this is a dupe... askubuntu.com/questions/33946/… –  fossfreedom Apr 1 '12 at 11:11

2 Answers 2

up vote 2 down vote accepted

Go to Edit → Preferences → Extensions, then disable the Sound Menu Integration (make sure that also the "Notification Area Icon" plugin is disabled).

share|improve this answer
    
Is there no way to disable notifications separately from the Sound Menu Integration? –  Dave M G Apr 1 '12 at 10:31
    
Update: Tried this and it unfortunately does not seem to stop notifications. –  Dave M G Apr 1 '12 at 10:35
1  
Sorry, I just tried this in a 11.10 virtual machine: if you have both plugins disabled, there are no notifcations. Plus, it seems the sound indicator integration is not influenced by this setting! –  htorque Apr 1 '12 at 10:57
    
Okay, this works now that the "Notification Area Icon" plugin is also disabled. Thanks for clarifying. –  Dave M G Apr 1 '12 at 13:13

In Natty, Banshee won't show up in the notification area, so I ran the following command:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'banshee']"

This adds Banshee to a "whitelist" of applications allowed to be shown in the notification area.

Logged out, and logged back in again. Then in Banshee, went to Edit -> Preferences -> Extensions. Disabled Sound Menu Integration and enabled Notification Area Icon. Then, right clicked the notification icon and disabled show notifications.

I then disabled Notification Area Icon extension, and tried re-enabling Sound Menu Integration. This, however, still showed notifications whenever the track was changed. I found out though, that you don't need the Sound Menu Integration plug in enabled for Banshee to work in the sound menu

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.