Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I bought my girlfriend a Wacom Bamboo CTH-470 recently and it is running well after installing wacom-dkms. I have now run into a wall that I don't know how to get around. The touch on the tablet will not turn off. I am running Ubuntu 12.04 Beta 2. I have tried turning the touch off from the wacom settings in the settings menu. The pen and touch both work perfectly fine, it is just that the touch drives her insane when trying to draw in myPaint.

share|improve this question

4 Answers 4

up vote 13 down vote accepted

I set up my Pen & Touch over a year ago so I may be wrong here. What I usually do is run in a terminal:

xsetwacom --set "Wacom BambooPT 2FG 4x5 Finger touch" touch off

This won't work for you as you have another tablet so try first


which should give you the parameters to use. First you need to get the name of your device (let's call it DEVICE_NAME), so try:

xsetwacom --list devices

This gives me for my Pen & Touch:

Wacom BambooPT 2FG 4x5 Pen eraser id: 11 type: ERASER
Wacom BambooPT 2FG 4x5 Pen stylus id: 12 type: STYLUS
Wacom BambooPT 2FG 4x5 Finger pad id: 13 type: PAD
Wacom BambooPT 2FG 4x5 Finger touch id: 14 type: TOUCH

Obviously the one which is of type TOUCH is the one to disable here. Here DEVICE_NAME would be Wacom BambooPT 2FG 4x5 Finger touch and DEVICE_ID would be 14.Then you need to know which parameter to disable, so try:

xsetwacom --list parameters

There's a plethora of parameters to enable/disable, and for each parameter name (let's call this PARAM_NAME) the type of value expected is explained. In this case we want to turn the Touch parameter Off, which you can do with the --set option. The syntax is:




If you're not sure what to put in place of PARAM_VALUE, try the --get option to see the current value:

xsetwacom --get "DEVICE_NAME"  PARAM_NAME

Hope this will help,


share|improve this answer
That did the trick. Thanks a bunch! –  Foxx Apr 18 '12 at 3:50
Don't forget that xsetwacom doesn't store the settings, so you need to run the command line every time you log on to your session. For convenience you could have the script bound to a keyboard shortcut (to be able to enable/disable touch at will) or you may even be able to bind it to a button or your tablet (never tried it though). –  Maxweel Apr 18 '12 at 12:19

I wrote this script so that I can control turning touch on/off no matter which computer I plug the tablet into (because these IDs change between machines). You might find it useful as well.


# kermit-internal-pytouch 0|1

import re, sys, subprocess
resp = subprocess.Popen(['xinput', '-list'], stdout = subprocess.PIPE)
out, err = resp.communicate()
WacomLine = re.compile('Wacom')
FingerLine = re.compile('Finger')
for line in out.split("\n"):
    if and
        identifier =
        num ="number")['xinput', '-set-prop', num, "Device Enabled", sys.argv[1]])
resp = subprocess.Popen(['xinput', '-list'], stdout = subprocess.PIPE)
out, err = resp.communicate()

I put this script in /usr/local/bin along with these two simple bash scripts to call it without having to remember the parameters...


kermit-internal-pytouch 0


kermit-internal-pytouch 1

That said, I find it really sad that there isn't better support for tablets in Ubuntu. Maybe one day Wacom will show our community some attention too...

share|improve this answer

Throwing yet another script in the batch, I wrote this one for myself. I have it in an executable file wacomtouch in a .scripts folder I added to my environment path. Thus, to disable touch, I only need to run wacomtouch off. It automatically detects all the params, so it theoretically works with any Wacom tablet automatically.

(This relies on the pcregrep package.)



#Isolate the id of the touch device automatically.
rawID=`xsetwacom --list | pcregrep -M 'TOUCH' | pcregrep -o 'id\: \d*'`
#Trim further
device=`echo "$rawID" | grep -o "[0-9]\+"`

xsetwacom --set $device touch $1

case $1 in
        echo "Tablet touch is ENABLED."
        echo "Tablet touch is DISABLED."
        echo "Invalid option. Must be either on or off."
share|improve this answer

OR Just use this simple app I made .

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.