Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to change files permissions from a different hard drive?

I have an USB3.0 external hard disk, partitioned to 3 NTFS partitions. When I plug the hard disk in, the 3 partitions automatically mounted under /media. So far so good. I can read and write to files, or mkdir, etc on these partitions. But I can't do chmod/chown on any of the files/directories on these partitions. The owner:group always myself, and the mode are always 700 for directories and 600 for files.

I have another partition on internal harddisk also mounted. That partition works fine. I looked the output of mount command, the only difference between mount options is that there is one extra 'default_permissions' on the external hard disks.

Anyway I can set the owner:group and mode on these files and directories.

share|improve this question

marked as duplicate by Ringtail, jrg Apr 7 '12 at 21:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
went digging around and found someone's suggestion on a similar question. The solution is to have a user mapping file in .NTFS-3G directory on the top level of this NTFS partition. It works. –  G. He Mar 31 '12 at 21:34

1 Answer 1

NTFS and FAT do not manage permissions, that are emulated on mount.

This means that once you mounted your NTFS hard disk you won't be able to change permission or owner of the files inside. You have to unmount and then remount it manually with the options you prefere.

The only case this is useful is when you want to execute files on the hard disk that is, by default, not mounted with execution rights.

Pay attention to the fact that the permissions are just emulated. This means that you can always unmout the partition and remount it with completely differente permissions and/or owner of the files.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.