Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Vagrant is a tool to build and manage virtual machines for developers. It has a getting started on Ubuntu guide that contains iffy-looking suggestions like

$ sudo ln -s /usr/bin/ruby1.8 /usr/bin/ruby  # wtf???

or installing RubyGems from source rather than from Ubuntu packages, and then using gem install to install vagrant itself.

I'm not feeling comfortable just following those instructions. Is there perhaps a PPA? Are there, perhaps, alternative tools that are packaged for Ubuntu?

share|improve this question
add comment

4 Answers 4

up vote 7 down vote accepted

12.04

Vagrant install vagrant 1.0.1 is now included in universe in 12.04 and you can install this via the Software Center.

share|improve this answer
1  
I can't make up my mind if I should mark your answer as accepted now, or wait until 12.04 will actually be released. –  Marius Gedminas Apr 6 '12 at 18:09
1  
The official packages are so old, it is better to download directly from vagrantup.com. –  Willian Mitsuda Sep 23 '13 at 0:41
add comment

Nowadays you can download self-contained .deb files from http://www.vagrantup.com/downloads.html

Not as good as a PPA, but at least you can introspect what files get installed where and remove the package cleanly.

share|improve this answer
add comment

There is nothing to worry about the instructions in this getting started on Ubuntu guide. Making a soft link to /usr/bin/ruby1.8 does not harm your system in anyway. Just go ahead with the tutorial and install vagrant.To install vagrant you can use:

  sudo gem install vagrant

As far as i know there is no PPA available for vagrant. The best method to install it is using the gem.

If you are feeling any difficulties feel free to post it here

share|improve this answer
    
Did that, found out Vagrant refuses to work with virtualbox-ose and wants me to install the closed-source version. Shrugged, uninstalled Vagrant. –  Marius Gedminas Nov 13 '10 at 19:00
    
"Thanks for wanting to use Vagrant! Unfortunately, this is not the way to install Vagrant anymore. We now make installers for the various operating systems Vagrant supports. Vagrant is no longer distributed as a RubyGem.[...] Note that the RubyGem version hasn't been updated in over a year and will no longer receive any updates. –  hwjp Apr 1 at 16:58
add comment

If you are using Ruby:

It's better to install it via Rubygems despite the website's recommendation of .deb installation. The website seems to be a little behind on updates. The instructions of the vagrant gem seem more up-to-date: https://github.com/mitchellh/vagrant

If Bundler is installing a sub-1.0.0 version of the gem:

  • put gem 'vagrant' above all other gems in your Gemfile and run bundle install.
  • if that still doesn't work, put gem 'vagrant', '~> 1.0' and run bundle install.

Sometimes bundler installs an old version of the vagrant gem if your other gems installed old versions of gems, like json.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.