Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Newly installed ubuntu 11.10 on a new Asus U46E laptop. /proc/cpuinfo correctly identified the cpu but shows only one core:

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 42
model name  : Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
stepping    : 7
cpu MHz     : 800.000
cache size  : 4096 KB
physical id : 0
siblings    : 1
core id     : 0
cpu cores   : 1
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc up arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 x2apic popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips    : 5587.63
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

I search here and found the answer to one post suggesting remove boot parameter 'nolapic'. However, on my particular laptop, ubuntu won't boot without this nolapic parameter. Is there anyway for ubuntu correly utility the full cpu power?

share|improve this question
Also, cpu Mhz show 800 is a bit suspecious, too. – G. He Mar 31 '12 at 16:04
when it's in idle it's down to 800 MHz for low power consumption. Now all cores are always used. Are they listed separately in cpuinfo or do you just have that one core as processor 0? 11.10 should recognize it automatically – con-f-use Mar 31 '12 at 16:48
The whole cpuinfo was posted above. I didn't see anywhere else about the other cores. – G. He Mar 31 '12 at 17:42
@G.He: Hi, have you resolved this issue? – pl1nk Jun 13 '12 at 0:13
No, I have not resolved this particular issue. Do you have the same computer? – G. He Jun 21 '12 at 15:44

Open a terminal and run sudo apt-get install htop

Then run htop. It will show you all your cores and there usage. If it does then don't worry about it.

You can also use the standard top utility, press 1 and it will display all cores.

If it still shows one check your BIOS in case there is a settings disabling other cores.

Any Linux distro needs no config for multi cores, and I would seriously consider the entire install as suspect if this is really the case.

share|improve this answer

nolapic essentially disables SMP so you're only going to see a single processor.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.