Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ruby on Rails on Ubuntu 11.10, but receiving this error:

$ sudo gem install rails
ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: rails requires activesupport (= 3.2.3), actionpack (= 3.2.3), activerecord (= 3.2.3), activeresource (= 3.2.3), actionmailer (= 3.2.3), railties (= 3.2.3)

How can I fix this?

Note: Git (1.7.5.4 ) and Ruby (1.9.2p290) are installed properly.

share|improve this question
add comment

1 Answer

Try this.

sudo gem install rails -v 3.2.2

And then you should be good to go.

share|improve this answer
    
unfortunately, it doesn't work... –  pzanetti631 Apr 2 '12 at 23:06
    
@PauloCassiano Try this: sudo gem update --system && sudo gem install rails -v 3.2.3 –  jrg Apr 3 '12 at 1:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.