Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used FFMPEG to extract portion (5 seconds) of a video like this:

ffmpeg -ss 00:30:00 -t 00:00:05 -i original.avi cut1.avi

and also like this:

ffmpeg -ss 1800 -t 5 -i original.avi cut1.avi

But what FFMPEG did was create a file starting at 00:30:00 and included the rest of the file instead of just 5 seconds. So instead of having a 5 second video clip, I now have the whole file except the first 30 minutes.

What went wrong?

I tried this with mencoder as well -- same result.

EDIT 1

Strangely, this worked on OS X....

EDIT 2

After rebooting Ubuntu, I found that ffmpeg worked fine. What process was turned off that did this though?

share|improve this question
    
yes, i just was just using it on mac os x and it worked great –  Trevor Rudolph Mar 31 '13 at 6:01
add comment

1 Answer

up vote 1 down vote accepted

have you tried with this

ffmpeg -ss 00:00:30.0 -t 00:00:10.0 -i input.wmv -acodec copy -vcodec copy -async 1 output.wmv

for more information , look at this http://superuser.com/questions/138331/using-ffmpeg-to-cut-up-video

share|improve this answer
    
Yes, I have already used this from the link that you provided. It works on OS X but not on Ubuntu 11.10. I wonder if a process/daemon needs to be restarted... –  drN Mar 31 '12 at 3:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.