Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use coolbits to increase fan speed of my Fermi GPU. 280.13 driver installed. Ubuntu 11.10

I edited /etc/X11/xorg.conf as follows, by pressing Alt+F2 and

gksu gedit /etc/X11/xorg.conf

I get

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 470"
    Option  "NoLogo"    "True"
    Option "Coolbits" "4"
EndSection

Started getting these messages,
Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap"

So I did this,

sudo aptitude install gtk2-engines-pixbuf

terminal,

a@z:~$ nvidia-settings -a [gpu:0]/GPUFanControlState=1

a@z:~$ nvidia-settings -q fans

1 Fan on z:0

[0] z:0[fan:0] (Fan 0)

a@z:~$ nvidia-settings -a [fan:0]/GPUCurrentFanSpeed=80

ERROR: Error assigning value 80 to attribute 'GPUCurrentFanSpeed' (z:0[fan:0])
       as specified in assignment '[fan:0]/GPUCurrentFanSpeed=80' (Unknown
       Error).

So, it's not working; I can't enter the fan speed percentage. Also from NVidia X Server, there are no fan controls.

http://en.gentoo-wiki.com/wiki/Nvidia#Manual_Fan_Control_for_nVIDIA_Settings

share|improve this question
    
Please, add a question to your problem. –  Masi Mar 30 '12 at 23:02
    
Option "Coolbits" "4" was the problem! Needed to use "5" - it then worked via X Server - Just accept the NVidia terms and as if by magic a fan slider bar appears. –  usk Mar 30 '12 at 23:39
    
Please, add that to the answer and accept it so we know that the thing is done. –  Masi Mar 31 '12 at 9:32

1 Answer 1

Copying the answer from above, so people like me can more easily find the solution...

'Option "Coolbits" "4" was the problem! Needed to use "5" - it then worked via X Server - Just accept the NVidia terms and as if by magic a fan slider bar appears. '

share|improve this answer
    
Accept the NVidia terms, yes, but where? –  ΤΖΩΤΖΙΟΥ May 23 '13 at 6:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.