Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had this problem before and now it's struck me again and with full force!

Here are the details of my hard drive:

  • 1 TB, HFS+ type partition mounted at /dev/sdb2
  • Doesn't have write access for some reason (I tried copying files to it and it wouldn't take)
  • chown my-user-name /media/hdd-name/* didn't work
  • This was not required as journaling was already turned off.
  • This has never worked.

What gives? What should I do?

EDIT 1

In /media when I run ls -l, this is what shows up for attributes for my external hdd:

drwxrwxrwx 1 99 99 24 2012-02-24 12:42 Untitled 1

Where Untitled 1 is the (clever) name for my external hdd... Who is the "99" bloke? :P

Any thoughts?

SOLUTION!!!

Yippeee!!!

chown -Rf dnaneet:dnaneet /path/to/folder/

Please do leave any comments, thoughts/feedbacks pertinent to this solution...


I am reading this right now to get better informed about sharing data between OS's...

share|improve this question
    
What does the mtab entry for the drive say when it is mounted? And do you have hfsprogs installed? –  jpd Mar 30 '12 at 19:53
1  
@jpd mtab entry says /dev/sdb2 /media/Untitled\0401 hfsplus ro,nosuid,nodev,uhelper=udisks 0 0. I don't have hfsprogrs installed but should be able to install with apt-get I am thinking? EDIT: Just installed hfsprogs –  drN Mar 30 '12 at 19:59
    
Does remounting read-write now work? sudo mount -o remount,rw /dev/sdb2 –  jpd Mar 30 '12 at 20:17
1  
@jpd remounting produces this message: mount: warning: /media/Untitled 1 seems to be mounted read-only. –  drN Mar 30 '12 at 20:22
add comment

1 Answer

up vote 1 down vote accepted

If your HDD is read-only, you will obviously not be able to chown your files. Afaik, hfs+ support isn't optimal (yet) under Linux. Have you installed all the necessary packages (I think you'll need hfsplus and/or hfsprogs)? Have you tried mounting it correctly?

This post might (if you haven't checked it yet) help you with these steps: http://superuser.com/questions/84446/how-to-mount-a-hfs-partition-in-ubuntu-as-read-write

Finally, you're talking about an external HDD: are you sure HFS+ is an appropriate choice for an xHDD? FAT32 is currently the most "universal" filesystem, and NTFS is starting to gain write support on most systems.

Sure, FAT32 and NTFS suffer from serious external fragmentation, but i don't think you use your xHDD to run an operating system or heavy applications directly on it, do you? :-)

Note that you need to chose between compatibility and functionality: both FAT32 and NTFS lack a proper ownership and permissions system, and FAT32 has a max. file size limit of 4GB on FAT32.

share|improve this answer
1  
So how should I change my file syste to NTFS or FAT32? By reformatting? –  drN Mar 30 '12 at 20:03
1  
And no, I use my external hdd to store files. I don't run anything off of it. Thanks for the tip though! –  drN Mar 30 '12 at 20:16
1  
Just tried what was on the superuser link... NO DICE! :( Made an edit to my question.. –  drN Mar 30 '12 at 20:20
    
Sorry for my late reply. Indeed, I don't think you can convert HFS+ to FAT32 or NTFS without formatting. And even if it's possible, I would still recommend doing a full backup. Working with partitions is always a bit risky. Since you're just storing, I once again highly recommend moving to NTFS (if you have files > 4Gb) or FAT32. At least until the HFS+ linux drivers become more mature. Note that working with NTFS under linux is a much more common problem than working with HFS+, hence the slight lack of resources regarding HFS+ & Linux... –  Mr. Pixel Apr 4 '12 at 11:28
    
@MRPixel Thanks though! :) –  drN Apr 4 '12 at 14:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.