Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am attempting to set up a private cloud using Ubuntu 10.04.4 Server. I am following the tutorial at http://cssoss.wordpress.com/2010/11/26/eucabook-v1-1/ . All steps go on perfectly apart from that I am unable to SSH into the running instances. I have created the instance using a public key and try to SSH into instance using the private key. However it asks for password. I am able to ping the instance though. I have tried using both the pre-built images from the store as well as custom built images.

Several people seem to have the same problem but there does not seem to be any working solution.

Thanks in advance.

share|improve this question

2 Answers 2

Turn on the "verbose" in ssh, which shows deugging messages : ssh -v . This may show you the problem right away.

Try regenerating the key with ssh-keygen -t rsa, and re-copying it to the server. That's worked for me when ssh is complaining about the key type (in verbose mode) and failing passwordless login.

Finally, check the permissions of your .ssh directory to make sure they are not too permissive.

share|improve this answer

Try this

ssh -i mykey.priv ubuntu@ipaddress-of-instance

This will not ask any password to enter.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.