Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two monitors attached to my video card. Primary monitor has a resolution equal to 1280x1024 and the second has 1920x1200. My gdm login screen always appears on the second monitor even if it is switched off. My question is how to force gdm to show the login screen always on the primary monitor with resolution 1280x1024?

I use Nvidia GT9500 videcard in Twinview mode. I can't use Xinerama because vpdau doesn't work correclty in this mode.

What I have found is that mouse pointer always appears in the center of union of the screens and center is always on the monitor with higher resolution. Login screen always shows where mouse cursor is.


Now my primary monitor has a resolution equal to 1920x1080. The problem still persists, mouse cursor always appears in the right-bottom corner of the second monitor.

share|improve this question
add comment

6 Answers

are you using a Nvidia card with a dual-screen setup?

If so, I had the same problem, and solved it the following way: Switch off the computer, unplug the second monitor, switch the computer back on, run 'sudo nvidia-settings', plug the second monitor back in, run 'Detect Displays' in the Nvidia GUI, and make the necessary configurations before saving the settings. The IMPORTANT point is that the screen that you wish the login to show up in is set to 'Screen Number: 0'.

In my case, leaving the second monitor plugged in before running 'nvidia-settings' left it as screen 0 for some reason, but by plugging it in after, this was sorted.

share|improve this answer
    
Yes, I use Nvidia card in TwinView mode. In this mode every screen is screen 0. So unplugging didn't help. –  Kirill Nov 7 '10 at 9:36
    
Okay, no experience with TwinView so sorry can't be of any more assistance –  spinoza666 Nov 9 '10 at 20:30
add comment
up vote 1 down vote accepted

Recently I have upgraded the system to the version 11.10. Ubuntu 11.10 uses a new display manager(lightgdm) and it seems that login screen is always appears on the primary monitor. This solves my problem.

share|improve this answer
add comment

For newer versions of Ubuntu such as 13.10 or upgraded 13.04 using Gnome 3.8, this procedure is different because the X configuration file no longer controls the monitor layout. You must do the following:

  1. Set the monitor layout correctly as a logged-in user (see Permanantly set monitor as primary)

  2. Copy the configuration file over to the gdm settings

    cp ~/.config/monitors.xml ~gdm/.config/
    

For more details, see https://bbs.archlinux.org/viewtopic.php?id=161903

share|improve this answer
1  
Confirmed, it works for GNOME 3.10 as well. The absolute location of ~gdm/.config/ is /var/lib/gdm/.config/ in case anyone else wonders. –  Forage Nov 28 '13 at 19:13
add comment

try switching the left/right order of your monitors, it doesn't change which one is primary, but it might help making your GDM show up.

share|improve this answer
    
it didn't help. –  Kirill Nov 6 '10 at 17:20
add comment

If twinview does it the same way the ATI catalyst control center does it, there is a xorg.conf you can edit with gksu gedit /etc/X11/xorg.conf

The relevant part of mine looks like this:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-0" 0 0
    Screen         "amdcccle-Screen[1]-1" 1400 0
EndSection

All you have to do (after backing up your xorg.conf of course) is change the ServerLayout by swapping the Screen entries (and adapting the screen numbers), in my case that would be:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-1" 1400 0
    Screen         "amdcccle-Screen[1]-0" 0 0
EndSection
share|improve this answer
    
I have only one screen defined in the xorg.conf so this doesn't help. –  Kirill Jan 12 '11 at 20:48
    
@Kirill: can you swap the plugs and then change screen ordering in the nvidia settings? –  Tobias Kienzler Jan 13 '11 at 8:57
    
It didn't help. Mouse always appears in the center of union of the screens and center is always on the monitor with higher resolution. Login screen always shows where mouse cursor is. –  Kirill Jan 13 '11 at 12:08
add comment

You can try "Separate X screen setting" on the NVIDIA X Server settings. If you set the desired display to 0, the login window will appear there. It's working for me.

share|improve this answer
    
I've tried this, but Gnome3 crashes each time on login in this mode. –  Kirill Dec 2 '11 at 19:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.