Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I just installed a Ubuntu 11.10 box and I'm trying to figure out how to set the timezone to UTC. I have it set to London at the moment, but UTC doesn't appear to be an option.

Help?

share|improve this question

marked as duplicate by Lucio, Charles Green, Eric Carvalho, KasiyA, Seth Oct 29 at 16:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
    
click on time indicator at top right conrner, you will get option of Time and date settings :) –  Web-E Mar 30 '12 at 15:25
    
I know how to change my timezone, but there doesn't appear to be a UTC setting. –  Thom Mar 30 '12 at 16:21
    
What exactly are you trying to do? Change the timezone in a server or a desktop version? If the desktop, are you trying to add UTC to the indicator-datetime or you want to configure the network time? Your question is a little ambiguous and would require some additional info about what you have already tried and where you tried adding UTC so we can better guide you. –  jokerdino Mar 30 '12 at 22:45
    
I think UTC appears there as GMT. –  viyyer Mar 31 '12 at 6:07

4 Answers 4

sudo dpkg-reconfigure tzdata

then go to Etc, there to UTC, enter, you're done. It actually changes files /etc/timezone and /etc/localtime.

share|improve this answer
up vote 9 down vote accepted

Unable to find UTC or GMT in the menu, I ended up running tzselect from the command prompt. I selected 11, enter posix standard time, then entered UTC-0. This appears to have done it.

thanks for all of the help.

share|improve this answer
    
Thanks, "UTC" only was too simple, struggled a bit with this. –  philant Nov 6 '13 at 15:53

To change the time zone for your user only on the command line; edit your ~/.bashrc file and add this to it:

export TZ=UTC
share|improve this answer
2  
Isn't that just my personal timezone? I'm trying to set the one for the server. –  Thom Mar 30 '12 at 16:20

This is an ugly hack, but it appears that Iceland uses year-round UTC. So setting the time zone to Atlantic/Reykjavik should work (at least until Iceland decides to change its default time zone).

(London doesn't use year-round UTC, so that's not going to work correctly.)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.