Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got the same problem as this gentleman: https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/176541

Where the webcam settings / access does not work at all / is completely unresponsive in Ubuntu 11.10.

I've tried webcam access in Facebook, Google+, my own code + a number of tutorials/demos and none work.

What happens is the settings dialogue is completely unresponsive. Clicking tabs or buttons does nothing.

In the question linked to a suggested answer is to run Unity 2D. Unfortunately this does not work for me (the exact same thing happens). I've also tried Gnome 3 which also does not work.

Note that it is only the webcam settings that don't work. YouTube videos and annoying banners work just fine.

Does anyone know of a workaround for this (except going back to 11.04) or if they've fixed this in 12.04? - also, are any of you experiencing the same thing?

share|improve this question
    
Can you add what kind of webcam it is? –  Jorge Castro Apr 25 '12 at 23:03
    
Not sure what I have tbh. But it doesn't seem to have to do with the model anyway. –  powerbuoy Apr 25 '12 at 23:08
    
It might, but it doesn't hurt to know it. Can you look at this question and then edit your question adding the information? It should show up in an lsusb –  Jorge Castro Apr 25 '12 at 23:10
    
It's not connected by USB, it's built in. Anyway, the problem is solved. And according to this: bugs.launchpad.net/unity/+bug/865672 it's a bug in flash or unity, not the webcam. –  powerbuoy Apr 25 '12 at 23:18
    
Anything in the logs that has a hint of the kind of webcam it might be? –  Jorge Castro Apr 25 '12 at 23:19
add comment

6 Answers 6

In my case the workaround suggested here did work: http://www.ironzebra.com/news/42/how-to-get-flash-webcam-to-work-on-ubuntu-linux . It requires to manually insert allowed sites.

share|improve this answer
    
Thanks for that –  powerbuoy Apr 25 '12 at 21:36
add comment
up vote 1 down vote accepted

As suggested in one of the replies to the question in the link in my question (what a sentence); logging into Unity 2D may solve it. It did not work for me. What did work, however, was logging into Gnome Classic (No Effects). From there I could interact with the settings dialog and enable webcam and microphone access for the sites I need it. After that, going back to Unity (normal) the webcam is activated.

share|improve this answer
add comment

Find Adobe Flash Player Settings app. Configure it (see photo 2). enter image description hereenter image description here For Google+:

Are you installed GTalk plug-in? You need it for Google Talk video chat. If you are not installed it, install it from Ubuntu Software Centre. enter image description here

share|improve this answer
    
Thanks for your reply. I do have the Google Talk Plugin installed and that actually works fine (I can do G+ Hangouts fine), the problem is exactly as described in the link I provided. I assume that your suggestion to use the "Adobe Flash Player Preferences" app instead will allow me to set which sites to allow and hence avoid the non-responsive settings dialog? Regardless, I've actually fixed it now by going into Gnome Classic (No Effects) and enabling it. –  powerbuoy Mar 30 '12 at 13:21
    
It is possible that access to the camera and the microphone is disabled for some sites. –  ZDroid Mar 30 '12 at 13:25
    
Hmm no, the problem is that when the dialog appears, it's completely unresponsive. Exactly the same problem as here: answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/… –  powerbuoy Mar 30 '12 at 15:23
add comment

Yes, it's an annoying problem with flash. The settings are not editable via right-click.

To solve this you can reach them from the flash-player-properties utility.

share|improve this answer
    
Actually, I can reach the settings through a right-click, the problem is that once there I can't do a thing. –  powerbuoy Mar 30 '12 at 13:06
    
Yes, I just modified the answer (sorry, I'm not native-speaker) because it wasn't what i meant :) –  dadexix86 Mar 30 '12 at 15:58
add comment

It is a bug. And it has not been solved in 12.04 yet. See https://bugs.launchpad.net/unity/+bug/865672.

share|improve this answer
    
I have the same problem in 12.04. My ubuntu 10.04 installation worked fine but when I upgraded to 12.04, this does not work. I am looking for some solutions. –  suresh May 6 '12 at 6:27
add comment

I recently converted (I hesitate to say "upgraded" as I'm yet to reach any hint of satisfaction) to 11.10 with Unity (not 2D), and as described, my USB camera stopped working on flash sites, with the options panel simply frozen and inaccessible.

However, I was able to get it working by going to the Adobe configuration page, where I was able to access the configuration options for my system. I located the website that I wished to allow access to the camera (I leave global permission set to "Ask" generally), change it to "Always allow" for that site only, and then refreshed the page I wish to use. Voila, it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.