Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm working on 11.10 for few recent days, everything was working perfect until today. Updated ubuntu (some certs were updates as far as i remember) and from this time, wired network stops working randomly and systematically. (All other pcs/macs work fine)

From 192.168.0.9 icmp_seq=25 Destination Host Unreachable
From 192.168.0.9 icmp_seq=26 Destination Host Unreachable
From 192.168.0.9 icmp_seq=27 Destination Host Unreachable
From 192.168.0.9 icmp_seq=28 Destination Host Unreachable
From 192.168.0.9 icmp_seq=29 Destination Host Unreachable
From 192.168.0.9 icmp_seq=30 Destination Host Unreachable
From 192.168.0.9 icmp_seq=31 Destination Host Unreachable
64 bytes from 192.168.0.1: icmp_req=32 ttl=64 time=1003 ms
64 bytes from 192.168.0.1: icmp_req=33 ttl=64 time=0.496 ms
64 bytes from 192.168.0.1: icmp_req=34 ttl=64 time=0.576 ms
64 bytes from 192.168.0.1: icmp_req=35 ttl=64 time=0.522 ms
64 bytes from 192.168.0.1: icmp_req=36 ttl=64 time=0.624 ms
64 bytes from 192.168.0.1: icmp_req=37 ttl=64 time=0.625 ms
64 bytes from 192.168.0.1: icmp_req=38 ttl=64 time=0.555 ms

It'll work for 20 seconds then it'll stop working for 10-30sec and so on. I've tried setting my router to give static IPs, it doesn't help. NOTHING has been changed since yesterday beside the package update...

Here are other settings that may be useful:

baka@baka-PC:~/Private/projects/wduk$ lspci -nnk | grep -iA2 net
06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards [1043:8432]
Kernel driver in use: r8169

baka@baka-PC:~/Private/projects/wduk$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr **Removed MAC address** 
      inet addr:192.168.0.9  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::ca60:ff:fe0a:85b2/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:6400 errors:0 dropped:6400 overruns:0 frame:6400
      TX packets:7085 errors:0 dropped:107 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:4191983 (4.1 MB)  TX bytes:886881 (886.8 KB)
      Interrupt:72 Base address:0x2000 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:2522 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2522 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1070130 (1.0 MB)  TX bytes:1070130 (1.0 MB)

baka@baka-PC:~/Private/projects/wduk$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 8.8.8.8

thanks for help

share|improve this question
    
This seems like an error I used to get alot, have you ever used amule on your system? Also, have you tried sudo dhclient eth0? –  RSX-1327 Mar 30 '12 at 11:22
    
It's a rig for work only, so there's no p2p or whatever. will do sudo dhclient eth0 now: RTNETLiNK answers: File exists –  Lukasz Baczynski Mar 30 '12 at 14:47
    
As said in the start i've set ip to static and restarted the networking service which didn't help. However I've restarted the system fully and now it seams to be working without problems. It's not a perfect solution but it works. Still don't know what's the cause of such behavior. –  Lukasz Baczynski Mar 30 '12 at 14:56
    
If your network problems persist, please post again. If you feel your problem has been solved create and answer and close your question! –  RSX-1327 Mar 30 '12 at 15:06

3 Answers 3

up vote 2 down vote accepted

Installing the r8168 driver will fix it.

share|improve this answer
1  
Indeed, along with Tim's answer on how to install the driver –  Lukasz Baczynski Apr 2 '12 at 9:48

I had a similar problem (intermittent wireless), and installing the correct drivers alleviated the problem. BUT, a note about drivers. For me the drivers offered by the OEM (ASUS) were not the most up to date for the Kernel on 11.10. I had to go to the website of the wifi chip manufacturer (Realtek) to get the correct drivers. Major headache to figure that out, especially for inexperienced linux users. For those drivers, go here: http://218.210.127.131/search/default.aspx?keyword=rtl8192

Additionally, I messed with the MTU setting in the wireless options. Even before I installed the new drivers that helped alleviate the problem (I suppose I was losing packets or soemthing). That may have also contributed to the fix.

Best of luck.

share|improve this answer

I'm not a "geek", But this also happened to me and I had to bootig from other programs to get back on the net, which you did also I presume;

This is what worked for me- In 'Edit Connections'- Under the connections at the top of the screen,go to "Connection Name"- this should be Auto(eth0)-MTU should be automatic-IPv 4 settings should be-Method: Automatic(DHCP). MAKE sure BOTH (Require IP4addressing for this connection to complete), And (Available to all users), are BOTH ticked in the little box, And IP v 6 settings-Method:Ignore, and tick the available to all users box.

             This worked for me, hope it works for you also
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.