Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a HP/Compaq s1010z (AMD64) desktop and installed 11.10 from a CD (using the entire disk). So it formatted the entire drive, went through installation and then it ejected the CD and asked me to click the Restart button, which I did. It rebooted fine the first time, but any time thereafter, it fails. Meaning, after the initial BIOS screen, the monitor seems to be stuck in limbo with a text cursor blinking on the top left corner, as if it can't find anything to boot from.

At first I tried reinstalling (reformat entire drive again) - no improvement. Then I did an in-place re-installation (leave home dirs in place, just redo the OS), nothing there either.

Then I put in the 11.04 CD, changed the boot order to CD first, and got the CD menu, chose 'Boot from first hard disk' and it booted fine. The problem is that I can't boot without the 11.04 CD, how ironic!

Any ideas?

share|improve this question

Use LiveCD, install and try Boot Repair.

share|improve this answer
Thank you very much, will try this tonight or tomorrow and report back on it asap. – bakhshu Mar 30 '12 at 22:09
This worked great, thanks for the tip! – bakhshu Apr 5 '12 at 17:17
Glad to hear that from you. It helped me a lot. Such a simple and useful software. – KeepTrying Apr 7 '12 at 3:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.