Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed a codec under the root user in my Ubuntu 10.04 installation. As you guessed, I can't play a movie using the codec under my normal user account. How do i rectify the problem?

share|improve this question
    
How did you install the codec ? If it was installed from a package, the user invoking the install is irrelevant. –  João Pinto Nov 6 '10 at 8:04
    
I installed using the root terminal <root@sly-laptop> from the command line interface. –  Andre Nov 8 '10 at 6:59
    
The command was apt-get install w32codecs. I want to enable the codec for all users :) –  Andre Nov 8 '10 at 7:07
2  
As a normal user you should never use the root terminal you must use sudo command. Uninstall w32codecs package and install this: sudo apt-get install ubuntu-restricted-extras. It will cover majority of codecs you will ever need. –  danizmax Nov 9 '10 at 19:01
    
Can the root user play a movie using the codec? –  belacqua Feb 15 '11 at 4:12

2 Answers 2

From your user account, try sudo apt-get purge w32codecs then sudo apt-get install w32codecs .

share|improve this answer

you can try installing again with you currently user use "sudo aptitude -y install non-free-codecs"

share|improve this answer
3  
One should never use -y unless you really know what you are doing... –  JanC Nov 6 '10 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.