Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Ubuntu using PXE Boot. I want to automate the whole process. But inbetween, it stucks at one point when it looks for ubuntu/main/oneiric/restricted/binary-i386/Packages file and gives a warning message that its corrupted. I have seen Ubuntu 11.04 64 bit, ubuntu 11.10 64 bit, ubuntu 11.10 32 bit DVD and its of the same size (1 KB). I am unable to predict why is it giving such a warning. I have attached the screenshot with the mail.

I want to know that if I have to replace packages.gz with the ones available on Ubuntu's repository, then what changes do I need to make and which files do I need to replace. Your help would be really helpful. Do let me know how we can suppress this warning or remove it.

Link displaying image when error occurs:-

https://docs.google.com/file/d/0B2XSUdG3GnDmQjFaZFpJRmRSVU9jc01pdkJLaWdJUQ/edit?pli=1

Thanks and Regards

Rahul

share|improve this question

3 Answers 3

up vote 1 down vote accepted

This file is part of the APT package repository; it sounds like you need to regenerate it with the tools for creating an APT repository.

Unless you've all of the other bugs worked out of your install process, I'd start by using an internet-based repository. Once the install process works, then make a local repository and test that for installing.

Alternately, set up the repository and test it by installing packages to other systems (not installations). Once you've got the APT repository working, then use it for installation.

There are a number of good documents describing how to do this; one is from Joseph Ruscio; one is from HiddenTao (Ramesh Nair); and one is from Stichting Lone Wolves of the Netherlands. There is also the Debian Repository HowTo.

share|improve this answer

I, too, ran into this issue and the most appropriate fix is to disable the Apache "MultiViews" setting for the directory that contains the installation tree. That way, Apache will return a 404 error for non-existent files rather than the contents of Packages* (which in this case ends up being 'Packages.gz') as it does with the default setting of MultiViews enabled.

Once I made this fix, my installations went off without a hitch.

share|improve this answer

I have met the situation before. I solved the problem by touch an empty file. Like

touch /var/www/ubuntu/dists/oneiric/restricted/binary-amd64/Packages

Hope it's worked for you.

share|improve this answer
    
I have tried creating an empty file, but still it doesn't work. It tries to do some MD5 checksum calculation and so even this method gives error. –  Rahul May 12 '12 at 9:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.