Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
    self.run()
  File "video.py", line 3381, in run
    self.player.loadPlugin("libbrowsernode")
RuntimeError: ./libbrowsernode.so: undefined symbol: _ZN3avg4Node7setThisEN5boost8weak_ptrIS0_EEPKNS_14NodeDefinitionE
share|improve this question

closed as not a real question by qbi, Jorge Castro, jrg Apr 24 '12 at 20:38

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer 1

There is very little to go on here outside of your error message. Not even a question outside of the title. What version of Ubuntu are you using? What were you doing when this error occurred? What version of the software are you using? What version of libbrowsernode are you using? Looking at this question and this question it looks like you need to work at filling out your questions with more detail.

Did you try what was recommended here? (That was you, wasn't it?)

This sounds like there is a version mismatch between whatever it is you might be running and with libbrowsernode - which appears to be part of Xibo. Make sure you are using the right version of libbrowsernode and make sure (using ldd) that your compiled code is finding the library.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.