Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

screenshot

It didn't fixed the error. So, how do I fix my GUI update?

For every software I have to install it from command line because I got same error when install software from Ubuntu Software Center.

share|improve this question
    
On Software Sources, Ubuntu software tab just change the "download from" parameter to "Server for España". That worked for me. –  user121740 Jan 12 '13 at 16:07

7 Answers 7

up vote 27 down vote accepted
  1. Write in a terminal: sudo apt-get update && sudo apt-get upgrade or edit Update Manager settings (try this first if you have already configured Update Manager).

    CLI

  2. Launch Update Manager and try again.

    GUI

Running update through a terminal gives option whether to allow or disallow untrusted packages.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

If you trust the package source, type y.

share|improve this answer

This happens due to the missing of some GPG keys. To fix this , Open a terminal and run the below commands:

sudo apt-get update

You will get an error saying that some public key is not available. Note the key string ( after the NO_PUBKEY; eg:D6B6DB186A68F637 )

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Replace the XXXXX with the key string

eg : gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

eg: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Now try updating your system again.

Here is a similar post: Error in Update Manager

Hope this helps.

share|improve this answer
    
tried this and I got the message that something has been created, but the update still didn't function. But evgeny's option worked, so no need to troubleshoot what went wrong with your proposal. –  rumtscho Dec 2 '10 at 18:50
    
sorry rumtsho. I forgot to add 'gpg --export ' command in my answer. I have updated my answer. Just try it. and check whether the update working or not. –  aneeshep Dec 3 '10 at 4:47
    
hmm, I get gpg: keyserver timed out; any suggestions? –  gatoatigrado Apr 21 '12 at 18:05

You can install it via the command line: sudo apt-get install --allow-unauthenticated exiv2.

To permanently "trust" the repo, execute this: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update. I believe that is the PPA you are using.

share|improve this answer
1  
Thank you, the "permanently trust the repo" is what I wanted to achieve and it worked. I just wonder why writing the address in the sources.list doesn't make it trusted, but apt-add-repository does. –  rumtscho Dec 2 '10 at 18:51
    
All packages are signed with a cryptographic key, "trusting" the repo involves getting the public key for that repository. You can read about public-key cryptography on Wikipedia. –  evgeny Dec 3 '10 at 5:06

Your question is unclear: you "fix your GUI update" by fixing the error. The other question will show you what to do.

You can deselect whatever of your updates is relying on an untrusted source, or you can go ahead and use the command line to trust that particular source permanently. Once you've done one of these, the message won't pop up. If you do the latter, then the message won't ever appear again for that specific source.

share|improve this answer

why its saying like that means , the packages you're trying to install are third party software.so if you want to install them , enable the Canonical Check box at other software Tab in the settings of update manager and then try again installing .

hope that helps .

share|improve this answer

In answer to your question, you cannot "fix" the GUI update (i.e. Update Manager), because it is apparent that that application does not currently have the capability of installing untrusted packages. If you want to install untrusted packages, you must do it at the command line.

There are, however, two ways you can stop Update Manager from reporting this error: either remove the untrusted software from your system OR trust the repository in question, as outlined in the answer to the other question ( Updates don't install because of "untrusted packages" ).

The first step is to find out which repository is causing the problem. You can find this out by typing apt-cache policy ambiance-colors at the command line.

However, a quick google reveals that ambiance-colors and radiance-colors are from ppa:ravefinity-project. So you should be able to fix your problem by typing

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

taken from http://www.webupd8.org/2012/01/ambiance-and-radiance-colors-theme-pack.html

share|improve this answer

I had the same problem. For me, this command worked:

sudo apt-get update --fix-missing

The advantage of this compared to the other solutions is its simplicity. You can continue to use the GUI and no need to find out which repository is broken. I found the solution here in a comment. I don't know Ubuntu enough to explain, but I suppose it gets the keys necessary for all the repos to work.

share|improve this answer

protected by Community Feb 11 '13 at 22:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.