Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know there's a lot of similar questions, but nothing I have tried here works yet - perhaps I was doing it wrong.

New Laptop - Toshiba Tecra R850 with an install of Oneiric 64 bit.

Mostly things are working well, but I have a problem with the touchpad (or whatever it's called) - whenever I use it for moving the mouse pointer I accidentally tap on it - basically I am clicking all over the place by accident. So I want to disable the tap-as-click (after all, I have buttons for clicks too).

I open up "Mouse and Touchpad" and on the Touchpad tab I check "Disable touchpad when typing" and UNcheck "Enable mouse clicks with touchpad". This does not achieve anything. Ditto Synaptiks and other similar tools.

EDIT

OK it turns out that this is a somewhat known problem - it seems the touchpad is not being recognized as a touchpad, it is seen as a PS/2 mouse. So any adjustments made with various settings programs to the "touchpad" don't affect it.

I've been looking at solutions for getting the touchpad correctly recognized and not achieved it yet - seems there is a problem at the kernel level...I tried (foolishly) a suggestion to replace the psmouse.ko driver ...this screwed some stuff up and didn't solve my problem.

So - anyone know an answer?

Thanks

Kibi

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Ha! found it eventually on Ubuntu forums. You'd think this would be fixed in the kernel by now...

I found this and worked for me - at this site http://ubuntuforums.org/showthread.php?p=11478976

I downloaded and installed the driver indicated from here: http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb

After installation and restart it works the way it is supposed to.

share|improve this answer

I also faced this problem before. Not only this touch pad makes problem for me while typing. For this reason, I disabled the touch pad. If you want to disable touch pad follow--- Go to-> System Settings--> Hardware--> Click Mouse and Touch Pad--> There are two tabs-- Mouse and Touchpad--- click touch pad and disable it.

I'm only a user. Not advanced user. Thanks

share|improve this answer
    
Sorry, that isn't really what I was looking for. I had to first get the touchpad recognized before I could use this setting –  Kibi Apr 9 '12 at 8:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.