Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I currently have 11.10 and 12.04 Beta running side-by-side. Since installing the beta, I am presented with a GRUB2 menu every time I boot up, which selects 12.04 by default. (Aside: when the 11.10 kernel updated from 3.0.0-16 to 3.0.0-17 this option did not appear in the GRUB2 menu.)

When I open Grub Customizer in 11.10, it shows 11.10 kernel 3.0.0-17 as the default, when I open Grub Customizer in 12.04, it shows 12.04 as the default.

How can I change GRUB2 to pick the latest 11.10 kernel as the default? (Latest means that if 3.0.0-18 is released it will become the default, and so on.) And also stop displaying the menu (I only boot into the beta when I have something specific to test).

Generic answers that apply to any two Ubuntus running side-by-side are preferred.

share|improve this question
1  
Is this question useful - askubuntu.com/q/54204/7163 –  Rory Alsop Mar 29 '12 at 9:29

1 Answer 1

You probably have the grub bootloader installed in two different locations, with different defaults for each. From your 11.10 install (i.e. the one you want to be default), run

sudo grub-install /dev/sda

then

sudo update-grub.

This should ensure that 11.10's version of grub is booted first when you turn on your PC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.