Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hey just installed XFCE on my Ubuntu 10.10 machine. But now I cannot log off or shutdown my computer. When I click on Log off or Shutdown nothing happens! If I again click on them a dialog box appears saying that :

Failed to receive a reply from the session manager

Session manager must be in idle state when requesting a shutdown

So how to fix this issue??

share|improve this question
    
which session manager are your system using? gdm or lightdm? –  shantanu Mar 29 '12 at 9:20
    
I am using GDM as a session manager... –  Ravi Mar 29 '12 at 9:32
    
reinstall gdm from synaptic manger or command line –  shantanu Mar 29 '12 at 9:35
    
Still no luck! Reinstalled GDM but the same error message appears again! –  Ravi Mar 29 '12 at 9:45
add comment

3 Answers

Simply try sudo shutdown -h now from your terminal.

share|improve this answer
2  
Do I always have to use this command? Can you tell another fix or why this is happening? –  Ravi Mar 29 '12 at 9:13
    
Are there any other processes running while you are attempting to shut down the machine? If you want to restart, there is another instance of shutdown you can use ctrl+alt+T sudo shutdown -r now. –  RSX-1327 Mar 29 '12 at 12:51
add comment
up vote 1 down vote accepted

I found the solution here is the link :

http://ubuntuforums.org/showthread.php?t=1948916.

Thanks all for replying and answering the question.

share|improve this answer
add comment

I got this problem simply because the ownership of the the $HOME directory was improperly set to root. It seems that the user must be able to write an an xfce4-session-* file to ~/.cache/sessions/. So attempts to shut down fail if this file is not present.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.