Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded my gnome shell to 3.4 in Ubuntu 11.10 through

sudo add-apt-repository ppa:ricotz/testing 
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get install gnome-shell

But it broke my system. Gnome shell is completely broken - When I login it just shows desktop wallpaper and nothing else.

And importantly Unity is also broken. Attaching the screenshot

Screenshot

Some main issues

1)Two menus are appearing now - Global menu as well as application menu
2)Icons on top-right panel are appearing weirdly
3)My Default Ambiance Theme also got screwed. Instead of black color menus, I am seeing white color menus.

How do I fix them? Or Do I have an option to revert back to original settings or will reinstalling Unity/Gnome Shell helps ?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

The best solution to your problem is to install Ubuntu 12.04 as Jeremy suggested above. Rather than spend countless hours trying to find a way to undo the damage you can start fresh. You can try to upgrade but if it's broken now it may be just as broken when you get done upgrading. Really it's easier to start with a clean install and avoid using packages that aren't meant to be used with your version of ubuntu. 12.04 is nearly out of beta anyways and will be supported much longer than 11.10.

share|improve this answer

If you can get to the terminal:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ricotz/testing 
sudo ppa-purge ppa:gnome3-team/gnome3
share|improve this answer
1  
GNOME 3.4 isn't supported on Ubuntu 11.10; you'll need to use Ubuntu 12.04 for supported GNOME 3.4. –  Jeremy Bicha Mar 31 '12 at 23:11
    
Yeah I did the same but still not much use –  mac Apr 5 '12 at 4:31

Try this:

Go to a Command Line Interface:

Ctrl+Alt+F1

Login, then type:

sudo apt-get install --reinstall unity && sudo reboot
share|improve this answer
    
did that. Not much use. I guess its not the problem with unity but with gnome settings –  mac Apr 5 '12 at 4:30
    
if like that, you have to uninstall gnome and all gnome settings. type as the first way, go to command line then login then type sudo apt-get --purge remove gnome-shell && sudo apt-get install --reinstall unity finally reboot. –  obysr May 1 '12 at 20:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.