Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.04 (upgraded from LTS 10.04) and Firefox (version 11) doesn't show it's icon in the Window List panel, in the Firefox window top left corner (system menu) nor when using ALT+TAB to switch applications.

I'm using unity 2D since I'm running ubuntu as a guest in a VMWare virtual machine (Host is windows 7)

Instead of the Firefox icon I get what appears to be a generic icon that looks like an app window in the window list and a black rectangle with a curl in the bottom right corner in the ALT+TAB window.

How do I fix this so that the proper Firefox icon gets displayed?

EDIT: Depending on the icon set chosen in the Appearence settings window sometimes I get the icon, sometimes I don't. When using Ubuntu classic none of the icon sets provide the icon for Firefox.

EDIT: I tried creating a new profile, didn't help. Also, if I run firefox from a terminal (using ubuntu classic), I get the following message 'failed to create drawable' and the browser does show up the proper icon. Is there a way what drawable failed? The message shows up even if I only bring up the command line parameters help (firefox -h), altho it shows in the middle of the output.

share|improve this question
add comment

3 Answers 3

up vote 0 down vote accepted

Alright, figured out hwo to solve the issue, although not quite 'why' it happened.

Seems I had installed a stand-alone version of Firefox (a Mozilla build probably, from mozilla.org). After a while the Ubuntu-supported version made it's way to the computer, not sure if during one of the OS upgrades.

So when I ran Firefox I was running the version installed in my user home folder (which had updated to 11, the current version at this point in time), which for some reason had trouble displaying the icon. (when running this version from a termina there are a bunch of gtk error messages).

When I ran Firefox from the command line, the version that ran was the version by Ubuntu Mozilla Team. This version managed to display the icon, despite the error message (which now I believe is not related). Both Firefoxs used the same profile data, hence the confussion.

So the solution is to just use the right version. Although still don't know exactly why the moz build had issues with icons.

share|improve this answer
add comment

Press Ctrl+Alt+T to open the terminal

type

sudo apt-get install --reinstall unity && sudo reboot
share|improve this answer
add comment

Press Ctrl+Alt+T to open a terminal then

unity --reset 
share|improve this answer
    
Or try 'sudo apt-get upgrade' –  HotrodJP99 Mar 28 '12 at 20:14
    
Perhaps you mean unity --reset? Doesn't seem to help. Neither did sudo apt-get upgrade –  frozenkoi Mar 29 '12 at 23:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.