Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I extracted the information from an ISO Image and from Nautilus I could only see two folders, but from the terminal I can see the rest of the files and folders. These folders do not have the . character in from of them to hide them from plain sight. When I try to "Show hidden files" in Nautilus, Nautilus closes/crashes itself and it does not show the hidden folders or files.

Somehow they are hidden without using the normal dot in the beginning of the filename. They have my user permission, but no way of seeing them from within Nautilus. I can interact with them, but the fact that they appear hidden when I can see them inside the ISO and after extracting them they disappear is what confuses me.

What permission or setting makes this folders appear hidden and does not let Nautilus show them and like I said before, trying to show them with the "Show hidden files" option crashes Nautilus and exits it, forcing me to have to open Nautilus again from the Launcher.

share|improve this question
    
Unmount and remount the above partition –  Tachyons Mar 28 '12 at 17:44
    
It was already mounted/unmounted many times. It was already moved to another directory just to try to fix it. No luck. –  Luis Alvarado Mar 28 '12 at 18:27
add comment

2 Answers 2

up vote 3 down vote accepted

Found this that solved the problem. Learned something new everyday: http://unix.stackexchange.com/questions/31688/options-for-hidden-files

There was a file called .hidden that just so happened to have the list of files that appear hidden but without the . in front of them.

After removing this file everything is shown in Nautilus.

So basically there are 3 ways to hide a file:

  1. Prefix the . symbol in front of the file/folder. If it was spore, after hiding it this way it should be .spore with a . (dot) in front of it.

  2. Add a ~ at the end of the file. If the file ends with ~, it is considered a "Backup File" and by default it gets hidden. If you have a file called spore and you change it to spore~ this would hide it and it would be considered a backup file. You can see that by default gedit for example does this.

  3. Create the .hidden file in the directory where you want to hide some files/folder. Inside the .hidden file add in each line the name of the file or folder you wish to hide.

share|improve this answer
add comment

As you said correctly, hidden files/folders have a . in front of the filename, indicating that they are hidden files, also called dot-files.

I never heard of this phenomena being possible or occuring before as you described it. What happens, when you use the ls -la command in terminal for that particular path/dir?! (Are those folders still shown without a .?!)

If you are certain about these folders being hidden folders, you manually could hide them by using the mv (move)-command, like so: mv /media/fun/misc/FOLDER /media/fun/misc/.FOLDER and see, if that resolves the "Show hidden files" crash in Nautilus.

share|improve this answer
    
That did not work and yes the ls -la showed the same thing as the image I put in the question. Very VERY weird. –  Luis Alvarado Mar 28 '12 at 18:29
    
Indeed very strange. Now i learned something new too. [+1]up for the nice explanation! –  v2r Mar 28 '12 at 18:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.