Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is there any setting/plugin/hack/workaround that will allow me to run Ubuntu with the Gnome 3.x/Gnome Shell desktop while retaining a 2x2 or n x m workspace grid instead of the default Gnome one-dimensional line-up of workspaces?

share|improve this question

4 Answers 4

up vote 4 down vote accepted

Pre-GNOME-Shell 13.10: With a combination of two extensions, it is possible. The downside is that you will have a bottom bar.

My blog post explains various ways on how to do this, including getting rid of the bottom bar (included below).

For 13.10, 13.12: Go to extensions.gnome.org and find Frippery Bottom Panel. Install it. This will give you a bottom bar. Clicking on the right side will give you an option to disable dynamic workspaces and allows you to set number of rows and columns.

The cleanest way of getting rid of the bottom bar is by editing

 ~/.local/share/gnome-shell/extensions/Bottom_Panel@rmy.pobox.com/stylesheet.css 

and on line 6, change the height to -3pt. Save the file. To activate the effect, GNOME-Shell must be restarted, so reboot, log out and in or restart GNOME-Shell by pressing Alt+f2, enter the command r and press ENTER.

Credit goes to Brian McSweeney.

share|improve this answer
2  
Nice! You can hide the bottom panel by editing ~/.local/share/gnome-shell/extensions/Bottom_Panel@rmy.pobox.com/extension.js. There, replace lines 787 and 788 with this.actor.set_position(primary.x,-h); and this.actor.set_size(primary.width,h);, respectively. –  Rasmus Jul 2 '12 at 18:33
    
Sweet! I tried looking at the code myself at first, but was overwhelmed, but this is incredible! Thanks for sharing. –  whirlwin Jul 2 '12 at 21:13
    
Could you add the basics of the answer in the answer, instead of just the link? –  Nanne Oct 30 '12 at 10:10
    
@Nanne I've added the how-to. –  whirlwin Oct 30 '12 at 10:20
    
I'd never seen the Alt-f2 command, so I looked it up, and it seems like it's used to run a shell command. However, while Alt-f2 and "r" do restart GNOME for me, "r" DOESN'T work from a terminal, which leads me to ask - why does it work from Alt-f2? Is there some list of special commands that that window recognizes? –  Erhannis Oct 12 at 3:17

There is now the plugin Workspace Grid, which seems to do the job.

It works for 3.8, but I not immediately for 3.10, 3.12. For those versions, I use the currently accepted answer.

enter image description here

share|improve this answer
    
Workspace grid does not work for 3.6.2. –  fakedrake Mar 27 '13 at 12:42
    
It's since been updated, and works fine on 3.6.3 here. –  supervacuo May 9 '13 at 10:23
    
Says it's outdated for 3.8, but if installed it still works. –  Rasmus Jun 26 '13 at 11:37
1  
It's since been updated, and works fine on 3.8 here. –  Kein Sep 17 '13 at 8:21

I was actually looking at this today, and the short answer is no. A hacky workaround is to have a gnome-panel running, with the workspace-switcher applet on it. This applet provides a setting for number of rows of workspaces, so you can create a grid layout.

I used to have a hack that was a daemon running in the background, which would handle this for me, so I wouldn't need the workspace switcher applet. It doesn't work any more though. However, I'll be rewriting it soon, so that it works again with GNOME 3.x, and using dconf/gsettings. It will only be configurable from editing the settings directly using the gsettings command line tool, or dconf-editor, though.

share|improve this answer

You can get a 1X1 workspace grid using the new WorkspaceBar extension I wrote. I will look into adding a 2X2 option if people want it. It would be small little buttons to fit on the panel.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.