Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been developing for android on eclipse for a while now, and my experience with the eclipse environment on Ubuntu10.10 has not been a smooth one.

With the repo install of eclipse I have had to sudo eclipse to install the required components for android development. (a big red flag for me)

I tried today to install updates for the eclipse and android platform and my eclipse installation seems to have broken horribly.

I can no longer find and of the urls for new software if i gksudo it, if I run it in user mode it fails (as it always has) with permissions problems. I have chowned user:user all my eclipse and android related private/user files.

This is a system running ubuntu 10.10 with gnome2.x. On my kubuntu 11.10 install it work a lot better.

  • Is there an easy fix to this?
  • Is the repo version of eclipse broken?
  • Should I do a clean install for just my user? (if so can I retain my previously installed software? the installation process is very time consuming) I saw there was a previous post here recommending this for new installations.
share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

This is no longer the case if you install from repository. Tested on 12.04 LTS Beta.

See this question with screenshots for verification.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.