Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I searched for other questions and googled a lot but I didn't find a solution for solving this problem.
I have Ubuntu Server 11.04 64bit installed on my Dell Poweredge with Intel Xeon X5450.

The server only recognizes 1 of the 4 cores I have. I tried to modify the GRUB config but it didn't work. In the machine BIOS I didn't find anything useful.

CPU

root@darwin:~# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Xeon(R) CPU           X5450  @ 3.00GHz
stepping        : 10
cpu MHz         : 2992.180
cache size      : 6144 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 xsave lahf_lm dts tpr_shadow vnmi flexpriority
bogomips        : 5984.36
clflush size    : 64
cache_alignment : 64
address sizes   : 38 bits physical, 48 bits virtual
power management:

GRUB

root@darwin:~# cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="noapic nolapic" #was with acpi=off

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Complete dmesg

Too long, posted on pastebin http://pastebin.com/bsKPBhzu

lshw -class cpu

 *-cpu:0
       description: CPU
       product: Intel(R) Xeon(R) CPU           X5450  @ 3.00GHz
       vendor: Intel Corp.
       physical id: 400
       bus info: cpu@0
       version: Intel(R) Xeon(R) CPU           X5450  @ 3.00GHz
       slot: CPU1
       size: 3GHz
       capacity: 3600MHz
       width: 64 bits
       clock: 1333MHz
       capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 xsave lahf_lm tpr_shadow vnmi flexpriority
       configuration: cores=4 enabledcores=4 threads=4
  *-cpu:1 DISABLED
       description: CPU [empty]
       vendor: Intel
       physical id: 401
       slot: CPU2
       capabilities: x86-64

Can't figure out. This last command shows that the cores are 4 and are all enabled.
The top command after pressing 1 shows me only CPU0.

share|improve this question
    
Could you post the output of dmesg too? –  Jeremy Kerr Mar 29 '12 at 1:07
    
added. thanks.. –  Kreker Mar 29 '12 at 10:29
add comment

1 Answer

up vote 3 down vote accepted

Your dmesg includes the log message:

[    0.016051] SMP disabled

From taking a look through the kernel source, it seems that the nolapic kernel parameter is preventing the kernel from coming up in SMP mode. If you remove this parameter, you should have all CPUs available.

Was there some reason for the noapic and nolapic parameters? If not, you should be fine.

share|improve this answer
    
Yeah! It works! Thanks! Don't know why there are these parameters, removed all and the trick did the job! –  Kreker Mar 30 '12 at 15:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.