Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i installed shotwell 0.12 like so via its official ppa

sudo add-apt-repository ppa:yorba/ppa
sudo apt-get update
sudo apt-get install shotwell

and when i tried to run it via dash it didn't start.
i then typed in the gnome-terminal "shotwell" I then got this error

error while loading shared libraries: libgexiv2.so.0: cannot open shared object file: No such file or directory

my question is how to get shotwell 0.12 up and running in ubuntu 11.10 amd64

share|improve this question
    
This looks like a new bug, starting today. I use the same PPA and 64-bit 11.10. I can't open Shotwell at all. –  Tom Brossman Mar 28 '12 at 17:25
    
do you also have Darktable installed? I do, and get 'unmet dependencies' errors with that package when I try to reinstall the library. –  Tom Brossman Mar 28 '12 at 17:38
    
Can you update Shotwell and test that it works again? If yes, you should accept one of the answers below. If not, update your question. Everything should work by now. –  Tom Brossman Apr 1 '12 at 8:22
1  
i updated shot-well and everything works great i accepted the answer of Adam dingle –  blade19899 Apr 1 '12 at 20:34
add comment

closed as too localized by Tom Brossman, gertvdijk, fabricator4, Ringtail, Luis Alvarado Jan 6 '13 at 4:27

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

up vote 2 down vote accepted

We just released Shotwell 0.12 yesterday, and unfortunately the 64-bit build failed on the Yorba PPA (though the 32-bit build worked fine). We don't know why yet:

http://redmine.yorba.org/issues/4949

Investigating this now is our top priority. I expect we'll have this worked out within a day or so. Thanks for your patience!

Adam Dingle, Yorba Foundation

share|improve this answer
    
It's working again, thanks. –  Tom Brossman Apr 1 '12 at 8:19
add comment

There seems to be a problem with Oneiric 64-bit. https://launchpad.net/~yorba/+archive/ppa/+build/3323887

I also got the same error, tried to reinstall Shotwell and necessary libraries, including from scratch (+libraries), but without any luck.

share|improve this answer
add comment

From the terminal

Try installing libgexiv: sudo apt-get install libgexiv*

share|improve this answer
    
i got an error of the .dbg package the rest i installed still shotwell didn't work. this is the error for the .dbg package the following packages have unmet dependencies: libgexiv2-0-dbg: Depends: libgexiv2-0 (= 0.3.1-0ubuntu2) but 0.4.0-0oneiric1 will be installed E: Unable to correct problems, you have held broken packages. a have a dutch version of Ubuntu the error i translated with google translate. –  blade19899 Mar 28 '12 at 16:25
add comment

I removed libgexiv2-0: sudo apt-get purge libgexiv2-0

Then reinstalled shotwell: sudo apt-get install shotwell

And this solved my problem.

share|improve this answer
    
This worked for me too, on Ubuntu 12.10 using the yorba PPA. –  Jim Garrison Mar 25 '13 at 1:01
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.