Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can you please help me ?

I tried everything I found and nothing worked. For example, I modified grub configuration file, installed xbacklight and tried setpci command.

share|improve this question
    
It looks like I have the same problem. Actually the nvidia settings allow to alter the brightness of the display. However I suspect that not the backlight is altered but the pixel colors. Thus I assume that it is not possible to save power by reducing brightness this way. –  user64908 May 20 '12 at 17:47
    
Have any of the answers resolved your problem? –  belacq Jun 11 '12 at 14:32
    
Try installing display drivers: askubuntu.com/questions/247145/… –  user142877 Mar 24 '13 at 6:25

4 Answers 4

Your best bet would be to reference this post, while it doesn't reference your exact machine many users have used this patch to fix their screen brightness problems. If you are starting to wonder about Toshiba Satellite backlit keys as well (just taking a jump here), its a known bug; and it has been flagged with a low priority by Canonical.

share|improve this answer
    
Thanks for answering ! When I press FN+F6 and FN+F7, nothing happens at all. In System Settings/Screen, when I try to move the brightness bar, same result : nothing. I tried keks-n's solution but it didn't work :( –  user52401 Mar 28 '12 at 6:57

Type su and enter root password in terminal

And then type this :

echo "x" > /sys/class/backlight/acpi_video0/brightness

where x = 0 - 7

share|improve this answer

-If use nVidia just open dash home and type "NVIDIA X server setting",

-Then click "X Server Color Correction" under X Screen O,

-Reduce the Brightness level,

-Click "Confirm current changes" before the time runs out,

-Choose Quit to save the change.

It worked for me with the following spesifications:

Toshiba Satellite L745

Intel Core i3

NVidia GeForce with CUDA

RAM 6 GB

share|improve this answer

I had the same issue on my Toshiba satellite L755. The new Nvidia driver v331.38 solved the problem. Now hibernation, sleep and fn keys for brightness work fine. Ubuntu 14.04LTS.

share|improve this answer
    
Could you please expand your answer detailing how to install the driver? –  Luís de Sousa 2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.