Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When my disk space for the ubuntu installation partition was getting low, from a live cd, I used gparted to increase its volume capacity, by deleting another partition and merging it to the ubuntu partition.

Since then, I am always receiving disk checking for errors at boot screen for my partitions.

What seems to be causing this and how can I fix it?

Update

Here is my boot.log if it provides few insight

fsck from util-linux 2.19.1
fsck from util-linux 2.19.1
/dev/sda1 was not cleanly unmounted, check forced.
ubuntu: clean, 501325/1310720 files, 2958455/5242880 blocks
/dev/sda1: 241/51272 files (3.3% non-contiguous), 73541/102400 blocks
mountall: fsck /boot [358] terminated with status 1
Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
...

/dev/sda1 is a separate grub partition for my dual OS's

share|improve this question
add comment

3 Answers 3

You're going to have to let it complete at least once. fsck is a legitimate health-check, and it's the "Right Thing" to do.

that said, if you ARE letting it complete, and it's still running every time you reboot, check the SMART results in the Disk Utility application (disk could be going bad), or adjust the frequency of disk checks with a command like:

sudo tune2fs -c 50 /dev/sda1

be sure to change the device to your actual device name, and feel free to adjust the count as well.

share|improve this answer
    
Yes, I am letting it complete and Smart results show "Disk in healthy" –  Starx Mar 28 '12 at 6:22
    
Is there a way to check the boot log, so may be you guys to see what actually is the problem –  Starx Mar 28 '12 at 6:23
    
fish around for any likely looking suspects in /var/log/, it can't hurt –  nathwill Mar 28 '12 at 15:42
    
I have updated with the boot log. Please see –  Starx Mar 28 '12 at 16:00
add comment

To disable file system integrity check for forever. Type following command

sudo tune2fs -c -1 /dev/sda

Where sda is your HDD.

share|improve this answer
2  
I would suggest to not stop the integrity check but to look into why it is checking it. The partition might have a problem (inode related, file corruption, etc..) –  Luis Alvarado Feb 7 '13 at 17:02
add comment

Your drive (partition /dev/sda1) is not being cleanly unmounted. In layman's terms: Your computer isn't shutting down that partition properly, and as a result your drive may have suffered damage - that's why this happens.

share|improve this answer
    
How can i fix it? –  Starx Mar 10 '13 at 9:30
    
Are you shutting down your computer properly? Also, knowing all the partitions on your system might be helpful (i.e. sda1: boot, sda2: home or whatever) –  whiskers75 Mar 10 '13 at 12:22
    
Yes, I used to. –  Starx Mar 10 '13 at 12:26
    
And by 'used to' you mean? –  whiskers75 Mar 10 '13 at 12:26
    
I don't have that system anymore. I installed Debian. –  Starx Mar 10 '13 at 12:27
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.