Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ubuntu 11.10 installed on an old 2008 macbook. There is an issue of screen dimming that I didnt find anywhere else on the forums.

The issue is that the screen is dimmed when I open certain applications (Firefox, Software Center) and this cannot be readjusted by the physical brightness buttons on the keyboard. I tried a bunch of things on the barely barely visible screen, and had no choice but to restart. This has happened everytime.

Does anyone know how to solve this?

share|improve this question
This is strange. I'm on 11.06 on a 2008 MacBook as well with no problems with screen dimming. Usually, I run Caffeine to keep my screen from dimming when I'm inactive, but I've never had a problem while I'm active or opening programs. I have upgraded the RAM to 4GB since I bought it; however, I doubt that would affect anything. Can you post more specifics? And are you sure it's not just that, while opening programs, you are idle for such a time that your screen dims? – weberc2 Apr 6 '12 at 13:15

On Mac

The mactel PPA modules needed on ubuntu on mac are mbp-nvidia-bl-dkms (for the LCD dimming support), and pommed (for the keyboard backlight control keys).

 sudo apt-get install mbp-nvidia-bl-dkms pommed

mbp-nvidia-bl-dkms must be in /etc/modules file to load. Open the file in an editor with:

gksudo gedit /etc/modules

And add to the end this line:

mbp_nvidia_bl shift=2

The shift option reduces the dimming range to make it more comfortable. You can tune the value as you want

for more go through this link from here I found this help I think this will help you I personally tried this helped me

If this not help see this link

share|improve this answer
My machine is an old macbook (not mbp) is there a version for older machines? (No keyboard backlights either) – yayu Apr 2 '12 at 9:02
@yayu can u tell me which version u use sudo dmidecode -s system-product-name – twister_void Apr 2 '12 at 9:12
Macbook 3,1 (character limit) – yayu Apr 2 '12 at 9:14
@yayu very unfortunate that Mactel Support for this version of MAc is not available see this for more on Mactel Community Documentation. here is the list of supported matrix – twister_void Apr 2 '12 at 9:19

This appears to be a performance issue.
Compiz dims unresponsive applications, and if the situation recurs when an application is opened, it most probably is because the application hanged. Firefox and Ubuntu software center at times take time to start on my machine, and the screen is dimmed when i open them, but i recover in few seconds.
Can you confirm that it happens only during opening certain applications? waiting for a while is all that is needed. But still, you will be able to open dash, open terminal with <ctrl>+<alt>+t and switch workspaces using <ctrl>+<alt>+<arrow keys>.

If absolutely nothing works, Then its a different thing. A machine with >=2GB ram should never have such problems. Can you comment with more details? Your RAM??
And try this.
Open firefox or software-center or any other troublesome application and redirect commandline output and errors to a file.
firefox &>~/mydebuglog
And if you are forced to restart, after restarting, see if anything was written to ~/mydebuglog. That might help.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.