Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu Meerkat(10.10) and my DNS fails.

I am connecting via proxy and I have set both $http_proxy variable and system wide settings for it.

When I try to ping 8.8.8.8 I get icmp response. However when I tried to ping www.google.com, it results in ping:unknown host google.com

I changed my /etc/resolv.conf file which had faulty nameservers. I gave: domain xx.yy.com search xx.yy.com nameserver AA:BB:CC:DD

However as the Network manager is set, when I restart networking, the resolc.conf gets reset to some other nameserver.

I know I can set static dhcp and change the interfaces file but I would like to work with NM. So please advice!

share|improve this question
    
I guess whenever I do sudo /sbin/dhclient, the DHCP changes the resolv.conf as well. Should I change dhclient.conf? –  user489152 Mar 27 '12 at 11:56
2  
Welcome new visitors to this page. It should be noted that "Support of Ubuntu Maverick Meerkat 10.10 was officially dropped on 10 April 2012". –  neon_overload Apr 9 '13 at 6:08

1 Answer 1

You need to properly configure network manager. Under ipv4 settings, select dhcp only and enter the name servers you wish to use.

You need to make sure then information you are entering is correct (AA:BB:CC:DD -> should that be AA.BB.CC.DD ?)

If you are entering the correct information , and resolv.conf is correct, did you enable your firewall (are you blocking dns traffic)?

NM

share|improve this answer
    
how do disable firewall? –  user489152 Mar 27 '12 at 13:15
    
I have a bigger problem at hand. Apart from wlan, eth0, eth1 is not even getting an IP from dhcp server. –  user489152 Mar 27 '12 at 13:16
    
The dhclient on eth0 results in: "There is already a pid file /var/run/dhclient.pid with pid 3306 killed old client process, removed PID file"... handshake messages and finally "No DHCPOFFERS recieved. No working leases in persistent database-sleeping" –  user489152 Mar 27 '12 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.