Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi sorry for asking this question i've googeled for this solution but i didnt find anything! I've installed tor or vadalia but when i want to run it it give me this error :

Vidalia detected that the Tor software exited unexpectedly.

I dont know how to stop it! sorry because i'm newbie in ubuntu and i knew that my qestion is so redculous but i need to connect to the internet by tor and i cant fix it ! tnxxxxx alot for responding!

share|improve this question

4 Answers 4

up vote 3 down vote accepted

In order to use tor. Install tor which will install polipo as a recommended package.

What you need to configure is polipo/privoxy for tor as your are using http proxy. Tor doesnot use 8118 as its port it uses 9050 and it is a socks proxy. You can use this configuration for polipo to use with tor. Just do:

sudo wget https://gitweb.torproject.org/torbrowser.git/blob_plain/HEAD:/build-scripts/config/polipo.conf -O /etc/polipo/config

sudo service tor stop && sudo service polipo stop

sudo service tor start && sudo service polipo start

tor needs to start before polipo, or else polipo will occupy the 9050 port and tor will start with errors

I am giving much focus here on polipo because tor itself recommends polipo and is installed by default on tor installation. You can use privoxy in place of polipo as well. Most of the tor users recommend using the default socks proxy if the application handles it.

If you want to connect everything through tor you need to set system proxy with System Settings > Network > Network Proxy

And then setup proxy to 127.0.0.1 and port to 8118. Use socks proxy where supported just change port to 9050 and type to socks5.

Optionally, install any browser proxy switch addons, I use chromium with proxyswitchy. Similary choose one for firefox if you use firefox. AFAIK pidgin, xchat, thunderbird support socks5 proxy. I think firefox also supports socks5.

TOR check failed though Vidalia shows green onion

share|improve this answer
    
tnx alot for your good answer but can you guide me more ? i wanna surf internet without any filtering ! you know in my country there are some problem with ..... and we have filtering system ! how can i surf the internet without any filter and safe and secure ? –  Mohammad Mar 27 '12 at 11:58
1  
have you tried above method ? Well tor itself says its experimental and not strong in anonymity. You must use some VPN for that I guess but you may need to pay for good service. Here are some alternatives in linux alternativeto.net/software/tor/… –  sagarchalise Mar 27 '12 at 12:08

If you are having trouble setting up Tor, a better option is often to use the Tor Browser Bundle, available at the tor website. The browser bundle does not need to be installed, you just run the start-tor-browser executable in the folder, once you've extracted it with Archive Manager.

share|improve this answer
    
this website is filtered in my country Unfortunately . how i can connect to the network without any net filtering ? like freegate or hotspot ? i've tried hotspot i didn't connect ro network ! and freegate doesn't start ! –  Mohammad Mar 27 '12 at 11:31

Assuming that "Vidalia" is the process you want to stop, run the following from a terminal:

ps -ef | grep Vidalia

Find the process in the result set, and look for the PID (Process ID). Assuming a PID of 31559, you can terminate the process with the following:

sudo kill -9 31559
share|improve this answer
    
In my defense, the original title of this question used to be "how do you stop a process." –  BryceAtNetwork23 Mar 27 '12 at 11:57
    
you're right i'm sorry –  Mohammad Mar 27 '12 at 12:19

I had the very same problem and here's the solution which was helpful to me:

Cause(observed):

The message you are getting when you switch on vidalia and consequently when vidalia tries to connect you to the tor network is because tor is set run on startup, meaning when you start vidalia there is already an instance of tor running on your OS and therefore it can't start another(maybe tor is programmed to one instance per session).

Solution(1):

Since tor is already running, use sudo ps -ax |grep tor to confirm, all you need is to configure your browser to route traffic through tor which i suppose you haven't. See "Browser config" below.

Solution(2):

If you want to operate, customize and/or switch on/off tor easily without the cryptic CLI then you might want to use vidalia. And for that:

sudo killall tor so that vidalia can launch tor as its child

then ask vidalia to connect you to the tor network and hopefully it will work.

Browser config:

Set your browser to use SOCKS proxy (v5 works, haven't tested it for v4) , ip address:127.0.0.1 and port:9050 when you want to use tor otherwise do not disturb this.

Note that tor will automatically run on each startup, so you'll have to kill it on each and every startup if you want to connect to tor using vidalia. The automatic cure to that which i choose was to use upstart because i didn't want to dig in the tor configs. Squashing is relatively easier.

If your ISP requires you to connect to the internet through proxy server then you'll have to set vidalia to use that proxy setting in order to connect to tor.

Note to readers i aint an expert hacker and many a things i've stated here are based on my observation which seemed quite plausible and might be wrong so please make corrections where ever needed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.