Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I maximize some of the windows all decorations disappear (by all, I mean on all windows)... Is that common issue on Unity or I'm just unlucky to have some prone to that bug configuration? Anyone have idea how to fix this?

It won't fix after unmaximize. It seems like maximazing window simply crashes window decorator. Decoration isn't displayed for all existing windows and any new ones. Only way I found to fix this is to run compiz --replace (but this ruins current windows placement - all windows end up on same desktop).

It happens almost every time I maximize window.

share|improve this question
    
I havent seen this issue but some things you could explain to help narrow down the issue are: can you attach a screenshot? Is this reproducible? Does it get fixed after you unmaximize, or does it stay the same way? Please edit your question to improve it. –  Aras Mar 27 '12 at 7:44
    
Open the terminal and type unity --reset –  Tachyons Mar 27 '12 at 12:33
    
@tachyons IT LITERALLY DELETED EVERY UNITY SETTING I MADE EVER! YOU COULD AT LEAST WARN WHAT IT DOES!!! –  korda Mar 27 '12 at 14:35
    
it will delete some compiz settings ,but you can re-enable it via ccsm –  Tachyons Mar 27 '12 at 15:09
    
You could also try Unity 2D and see if that happens too –  Christian Vielma Mar 27 '12 at 15:44
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

I have begun experiencing this very recently(yesterday) as well. Going into compiz settings manager and unchecking "windows decorations", then re-checking it, seems to "fix" it, although it does continue to happen, causing me to have to open up compiz fairly often. Hopefully a fix will be found soon.

Edit!: Fixed this issue for myself by entering Compiz Settings (CCSM), going into the Window Decorations menu, and changing the Command setting from:

gtk-window-decorator --replace

to:

/usr/bin/compiz-decorator

Backing out of this menu, then unchecking Window Decoration, allowing the desktop to reload, then checking Window Decoration and exiting out of CCSM.

After doing this, I've tested multiple applications, in various combinations of maximizing, minimizing, re-sizing, opening, closing, etc and can no longer reproduce the issue. The titlebar and everything stay exactly as they are supposed to. I don't remember ever changing this setting personally, though it is possible I did at some point, or gave compiz permission to while messing with another setting, but for me this has seemingly fixed the issue. Hopefully it will help you as well.

share|improve this answer
    
Well it seems that unity --reset (tachyons comment below my question) left /usr/bin/compiz-decorator there too... However it is nice to know how to fix this without losing all my settings :) I'm also not 100% sure if there was gtk-window-decorator --replace there before, but I don't want to risk messing around it to check if issue is linked with it in my case too... –  korda Apr 2 '12 at 6:55
    
I know I had been trying to set up the infamous "cube" in my case, just before I started having these problems, and then trying to get things back, and I changed and unchanged a number of compiz settings in this process, often with it saying things like , "This will cause such-and-such conflict. Resolve conflict?" and me being foolish enough to click yes without first learning what was going to be changed. So I am imagining that in that process I agreed to something which changed that setting. This is, of course, conjecture at this point. –  Edub Kendo Apr 2 '12 at 8:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.