Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed a Linksys Wireless-N Notebook Adapter w/Dual-Band (WPC600N), which is working nicely via the PCMCIA slot; however, I cannot find where to permanently disable the internal WiFi adapter. Currently, I'm forced to manually disable it with each reboot.

share|improve this question
    
Is there a BIOS setting you can switch? –  zpletan Mar 27 '12 at 3:15

2 Answers 2

Unless there is a hardware switch to turn it off, just blacklist the module.

You can find out which module is in use with this:

lspci -nnk | grep -iA2 net

...to blacklist a module, add blacklist module_name to /etc/modprobe.d/blacklist.conf

share|improve this answer
    
Thanks for the information. Being an old DOS hack, I was able to figure out what changes to make and where to make them, but I've been unable to save them to the blacklist.conf file. i don't seem to have permission to modify the file. Any comments? –  Stan Haskell Mar 30 '12 at 8:09
    
You have to open it with super user privileges, like this: gksudo gedit /etc/modprobe.d/blacklist.conf. If you need help with the module names, post the output of lsmod. –  mikewhatever Mar 30 '12 at 10:22
    
Thanks mikewhatever, I'll give that a whirl. Hopefully, there won't be any follow-up questions. I appreciate your time. –  Stan Haskell Apr 2 '12 at 22:21

Add the following line to /etc/network/interfaces:

iface wlan0 inet manual

(Replace wlan0 with the interface you want to disable)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.