Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today after trying to install and remove BURG and few themes I faced an issue. Now I can't install or remove anything.

Here is the output (unfortunately partly in Finnish, I couldn't change language since it also seems to depend on package listings:

lassi@lassi-ubuntu:~$ sudo apt-get autoremove
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatietoja... Valmis       
Seuraavat paketit POISTETAAN:
  burg-theme-fortune burg-theme-gnome burg-theme-picchio
0 päivitetty, 0 uutta asennusta, 3 poistettavaa ja 0 päivittämätöntä.
3 ei asennettu kokonaan tai poistettiin.
Toiminnon jälkeen vapautuu 7 180 k t levytilaa.
Haluatko jatkaa [K/e]? k
(Luetaan tietokantaa... 166462 files and directories currently installed.)
Poistetaan pakettia burg-theme-fortune...
sudo: update-burg: command not found
dpkg: virhe käsiteltäessä burg-theme-fortune (--remove):
 aliprosessi installed post-removal script palautti virhetilakoodin 1
Poistetaan pakettia burg-theme-gnome...
sudo: update-burg: command not found
dpkg: virhe käsiteltäessä burg-theme-gnome (--remove):
 aliprosessi installed post-removal script palautti virhetilakoodin 1
Poistetaan pakettia burg-theme-picchio...
sudo: update-burg: command not found
dpkg: virhe käsiteltäessä burg-theme-picchio (--remove):
 aliprosessi installed post-removal script palautti virhetilakoodin 1
Käsittelyssä tapahtui liian monta virhettä:
 burg-theme-fortune
 burg-theme-gnome
 burg-theme-picchio
E: Sub-process /usr/bin/dpkg returned an error code (1)

Basically what seems to happen is this:

It creates the package lists, then tries to remove packet burg-theme-fortune. This fails as update-burg command was not found. Then dpkg reports an error while processing the packet.

Same goes with all 3 packages.

In the end it claims that there were too many errors, and packages stay installed.

I also tried installing burg as it tries to run command update-burg, but appears that it tries to delete these packages always when I try to install or remove or do anything with apt.

Any ideas how I could solve this issue?

Edit: Here is the output of apt-get install burg (tried installing again to get English output)

    lassi@lassi-ubuntu:~$ LC_ALL=C sudo apt-get install burg
[sudo] password for lassi: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
burg is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/6169 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 167497 files and directories currently installed.)
Preparing to replace burg-theme-fortune 0.5.0-1 (using .../burg-theme-fortune_0.5.0-1_all.deb) ...
Unpacking replacement burg-theme-fortune ...
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error processing /var/cache/apt/archives/burg-theme-fortune_0.5.0-1_all.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Preparing to replace burg-theme-gnome 0.5.0-1 (using .../burg-theme-gnome_0.5.0-1_all.deb) ...
Unpacking replacement burg-theme-gnome ...
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error processing /var/cache/apt/archives/burg-theme-gnome_0.5.0-1_all.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Preparing to replace burg-theme-picchio 0.5.0-1 (using .../burg-theme-picchio_0.5.0-1_all.deb) ...
Unpacking replacement burg-theme-picchio ...
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error processing /var/cache/apt/archives/burg-theme-picchio_0.5.0-1_all.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
Generating burg.cfg ...
/usr/sbin/burg-probe: error: cannot stat `/boot/burg/locale'.
No path or device is specified.
Try `/usr/sbin/burg-probe --help' for more information.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/burg-theme-fortune_0.5.0-1_all.deb
 /var/cache/apt/archives/burg-theme-gnome_0.5.0-1_all.deb
 /var/cache/apt/archives/burg-theme-picchio_0.5.0-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
lassi@lassi-ubuntu:~$ 
share|improve this question
    
What happens when you re-install burg, remove the theme(s) and then remove burg again? –  MrChrisDruif Mar 26 '12 at 20:11
    
I tried force installing BURG and what got mainly errors. I added the output of installing BURG to the main post. –  Lassi Mar 26 '12 at 20:22
    
Also, it would help, if you try to get English output preprending the commands with LC_ALL=C, e.g.,, LC_ALL=C sudo apt-get install burg. –  htorque Mar 26 '12 at 21:31
    
@htorque Your method did work. Thank you! –  Lassi Mar 27 '12 at 5:14
add comment

1 Answer 1

up vote 2 down vote accepted

This is a long shot, but you can try:

sudo mkdir /boot/burg
sudo touch /boot/burg/locale

Then try again to reinstall burg:

sudo apt-get install --reinstall burg burg-theme-fortune burg-theme-gnome burg-theme-picchio

Once everything is installed, remove the themes first, and finally Burg.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.