Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to assign custom shortcut to launch my own script (I don't need it in terminal window, just launch it)

So, I went to Settings -> Keyboard -> Shortcuts -> Custom Shortcuts, pressed the button with "+" and entered the name of shortcut and the command itself. But then I cannot bind keys to that shortcut. I selected a new row and pressed needed keys (Shift + F3) and nothing happens. I can change the keys for system shortcuts, but do not have any luck with my own.

Any ideas?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

For custom shortcuts, you can't bind your keyboard shortcut if you only selected the row. This is different from how it works for System shortcuts, where merely selecting the row is enough to input a new keyboard shortcut.

enter image description here

You have to click on the Disabled and wait for it to change to New accelerator.... After that you can press your desired keyboard shortcut and it will be reflected appropriately.

enter image description here

share|improve this answer
    
Very clear behavior.... Thanks a lot! –  krasilich Apr 1 '12 at 10:27
    
So user friendly, thanks a bunch! –  umpirsky Nov 6 '12 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.