Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to SSH to a machine and initiate a VPN, created whilst in front of the machine through GNOME (Ubuntu 10.04.4 LTS);

$ nmcli con 
NAME                      UUID                                   TYPE              SCOPE    TIMESTAMP-REAL                    
Auto eth0                 ebd17105-b46d-4405-893e-4da47c592861   802-3-ethernet    system   never                             
br0                       3f94195e-bece-45a4-af6f-400879063ea6   802-3-ethernet    system   never                             
NAME                      UUID                                   TYPE              SCOPE    TIMESTAMP-REAL                    
testvpn                    0da910b2-e094-43ed-8c12-fd078fe7d52a   vpn               user     Tue 12 Jul 2011 22:52:39 BST      
myvpn                   c6157e94-3713-498d-a9a7-35eb1aae40ab   vpn               user     Mon 11 Jul 2011 22:01:16 BST

$ nmcli con up id myvpn
Error: No suitable device found: no active connection or device.

I have been searching the Internet but can't find any answers. I think it must be something to do with the fact that eth0 is a member of bridge br0 (I run KVM machines), and I get the same error on another machine which again, has eth0 in br0, for use with KVM.

Do I need to tell nmcli perhaps that br0 is active?

share|improve this question
1  
here is a bug report: bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/… As a workaround it would be possible to create the vpn connection from a virtual machine. –  Wimmel Sep 7 '12 at 18:16
    
I see, yes this is my problem. I will have to deal with it for now, thank you for pointing this out though. Good to see it has been acknowledged. –  jwbensley Sep 8 '12 at 10:19
add comment

closed as off topic by Jorge Castro, Stephen Myall, Ringtail, Mik, belacqua Nov 21 '12 at 17:24

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.