Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm unable to make Thunderbird open the default browser.

In the browser preferences, Chromium is selected as the default browser. It's also selected in "Default Applications" in System Settings.

In Thunderbird, I read "Chrome (Default)" which is wrong on all levels:

  1. Chrome itself complains that it's not the default browser when I click a link inside Thunderbird.

  2. In all other places, that I could find, Chromium is the default

Here is what I tried:

  1. I used update-alternatives --config x-www-browser to select chromium-browser as well (see How do I change the default browser?).

  2. And even when I select a different browser from the list in the Thunderbird preferences, it still opens Chrome.

My current solution is to create a link from /usr/bin/google-chrome to chromium-browser.

How can I force Thunderbird to use the browser I want???

EDIT I also updated gnome-www-browser (update-alternatives --config gnome-www-browser) after feedback from roadmr but that didn't help. At least sensible-browser opens Chromium, now, but Thunderbird is stubborn.

share|improve this question
add comment

3 Answers

A stab in the dark: did you use the update-alternatives procedure to update gnome-www-browser?

update-alternatives --config gnome-www-browser
share|improve this answer
    
Took me a moment to see the difference (gnome-www-browser instead of x-www-browser) but no game. At least sensible-browser now opens chromium, too. What worries me is that Thunderbird ignores its own preferences :-( –  Aaron Digulla Mar 26 '12 at 10:15
add comment

I found the last step missing. You have to go to Edit->Preferences->Advanced->Config Editor and change options

  • network.protocol-handler.warn-external.http
  • network.protocol-handler.warn-external.https

to user-defined. Next time when you open a link it will ask you about which browser do you want, and then type /usr/bin/x-www-browser.

share|improve this answer
    
As I said in my question, I already changed the preferences you mentioned but this had no effect. For some reason, Thunderbird ignores those settings :-( –  Aaron Digulla Jun 8 '12 at 17:58
    
That was the only option that worked for me. Placing the network.protocol-handler.app.http doesnt do anything. You essentially have to ask it to prompt it for you when you open a link... :S –  bruno.braga Apr 28 '13 at 23:42
    
Weird, but this actually does work. You'll want to mention the fact that these two entries are actually booleans and that you'll want to toggle them to True. –  Raceimaztion Jun 4 '13 at 9:30
add comment

I encountered a somewhat similar problem on Kubuntu 12.04 after installing Chrome. While T-bird continued to open http-protocol links in Firefox, it suddenly began opening https links in Chrome.

Going to Edit-Preferences-Attachments I found the entry for the Content Type http set to firefox, but there was no entry for https.

Using the information I found here, I modified the about:config file for T-bird, with the Config Editor, (found in Edit-Preferences-Advanced-General) to have the network.protocol-handler.warn-external.https use the boolean value of True, thus enabling a user-set value. Upon returning to Edit-Preferences-Attachments I then found an entry for https content and was able to set it to firefox. I found in unnecessary, in my case, to modify network.protocol-handler.warn-external.http

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.