Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Arduino IDE is based on a java application called processing. While typing text into processing, it refuses to accept any of the characters under dead keys like " ' ^. As a work around I:

  • Open another window (usually my browser or mail client);
  • I type the character I need;
  • Select and copy the character onto my clip board;
  • Copy the character into processing.

What do I have to do to make processing accept characters under dead keys? Disabling dead keys is not an option.

share|improve this question
    
I tagged this question as 'shortcut-keys', but I feel it should be tagged as 'dead-keys'. I haven't got enough rep to add a new tag. Can someone consider the 'dead-keys' tag? –  jippie Mar 26 '12 at 7:07
add comment

1 Answer

up vote 0 down vote accepted

I finally managed to figure out a work around. In KDE the keyboard configuration can be set in:

  • System Settings
  • Keyboard Settings
  • Layout
  • Select 'Show indicator'
  • Select 'Per window'
  • Add
  • Select a variant without 'dead keys', eg. "English (US, with Euro on 5)"

After applying these settings, I select the window for input focus and I click the indicator in the system tray when I want to switch the keyboard configuration. The keyboard setting needs only be set once per window and is rememberd over program restarts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.