Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having trouble running the script to install the gnome-shell-google-calendar extension into Gnome Shell. I keep getting this:

rafael@Raf:~$ ./calendar/gnome-shell-google-calendar.py
Logging in as 'None'...
Please choose the Account: I enter my email here
Traceback (most recent call last):
  File "./calendar/gnome-shell-google-calendar.py", line 455, in <module>
    account = oauth.oauth_prompt()
  File "/home/rafael/calendar/oauth.py", line 25, in oauth_prompt
    email = accounts[int(raw_input('Please choose the Account: '))]
ValueError: invalid literal for int() with base 10: 'email address'

I replaced my actual email address with the words email address for privacy purposes.

A bit more info on this extension can be found here: https://github.com/jnns/gnome-shell-google-calendar http://maketecheasier.com/integrate-google-calendar-into-gnome-shell/2011/10/04

Is there a way of fixing this?

share|improve this question
add comment

4 Answers 4

I've tried to run the version you have, but it didn't even ask me my email address, however I had a working version from https://github.com/vintitres/gnome-shell-google-calendar for a few months already. It has even added features like excluding calendars from importing.

share|improve this answer
add comment
up vote 3 down vote accepted

Ok so I found the solution to my problem: First I added my google account to Online Accounts

Then I followed the steps in this tutorial exactly: http://www.webupd8.org/2011/09/google-calendar-gnome-shell-integration.html

Works perfect now :)

share|improve this answer
    
While this may answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  michaelms Apr 12 '12 at 15:22
add comment

You need to set up your Google account in Online Accounts (System Settings -> Online Accounts). Once you've done that, run the script again and you will see a list of Google Accounts with numbers to their left. At the prompt enter the number for the account you want to use, and voila - works perfectly for me.

share|improve this answer
add comment

Looks like the script is expecting a number to select between a list of address, not a new address.

accounts[int(raw_input('Please choose the Account: '))]

It's using your input as a list index (most likely, it could be a dictionary too, but them casting it to a int doesn't make sense).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.