Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 LTS on my 2008 MacBook and removed Mac OSX completely so that it would just be Ubuntu. At first I was having issues with booting. I would have to hold option/alt on startup to select the disk to boot to. I eventually fixed that by "blessing" the disk in the Mac OSX install dvd with

bless -device /dev/disk0s2 -setboot -legacy -verbose

and it worked. The problem is I had decided to partition my hard drive and install linux Mint 12 on the partition. I finished installing but now when I start up the MacBook, I can't boot from either of the partitions. Even if I hold option/alt on startup to select a disk, nothing comes up. I tried blessing one of the disks again but it doesn't work now. The only way I am able to boot into either of my operating systems is by inserting the Linux Mint dvd and selecting "boot from local drive.." Is there any way I can fix this? I have next to no idea what I'm doing and I would like to be able to boot to one of my operating systems without having to use a DVD.. Please help.

share|improve this question

closed as too localized by RolandiXor, Eliah Kagan, Luis Alvarado, Tom Brossman, fabricator4 Jan 2 '13 at 9:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You still working on this? –  Chan-Ho Suh Apr 19 '12 at 7:21
1  
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  RolandiXor Jan 2 '13 at 4:17
    
This sounds like a Mint question, not an Ubuntu question. Is Ubuntu currently installed? –  Tom Brossman Jan 2 '13 at 8:13

2 Answers 2

Wow, why doesn't this have an answer already? It should be pretty simple, actually.

Just boot from your Snow Leopard DVD with the C key, as I'm sure you already know how to do. Inside the OS setup, there is a collection of tools that will help you, Disk Utility, Terminal, Network Utility, Firmware Password Utility, and Boot Disk Utility. Sadly, I've moved onto Lion, and can't say exactly where, but it's very close to the terminal you used to bless the drive. What you're looking for is something along the lines of "startup disk". Select what you want, and that will tell the firmware what to look for at boot time.

Had a nasty time with that while trying to install another, more "paneful" bit of software. Should fix you right up, assuming you haven't figured it out already.

Good luck, hope it helped.

share|improve this answer
    
The problem is that I have tried that. When I use the Startup disk tool from the Mac OSX dvd, nothing is available to select. Since I have had this issue, I have reinstalled Mac OSX 10.6 and spent some time repartitioning and whatnot. But I have the setup that I want now. Thanks for the suggestions. –  Adrint May 10 '12 at 19:40

I don't have a mac but don't you need rEFIt http://refit.sourceforge.net/ to boot linux on a mac, as they don't use a BIOS?

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.