Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I am using Ubuntu 11.10 with Gnome 3 installed. I have issues with the fan (I know that there are many threads about this but nothing has worked).

I am using Dell Studio XPS 1640 running core2duo 2.67Gz intel processor and Ati radeon hd (mobility) 4670. If you need anymore specs, please let me know.

I just installed Ubuntu again trying to get everything sorted out. I then imediately updated:

sudo apt-get dist-upgrade

And then I install gnome 3

sudo apt-get install gnome-shell

Then I DID NOT install the proprietary drivers provided by ATI because I know that they are incredibly unstable with Gnome 3 (plus a ton of errors that I lived with on Unity for about 2 months including screen tearing, half the screen doesn't draw/update and lots of crashes).

The ui is smooth and fast with the open source ati drivers (installed when Ubuntu was installed). I then tried to reduce the fan by installing Jupiter:

sudo apt-get install jupiter

And CPU freq

sudo apt-get install indicator-cpufreq

And running sensors:

sudo apt-get install lm-sensors
sudo sensors-detect

I also read that I was suppose to run fancontrol

sudo pwmconfig
sudo fancontrol

However running pwnconfig gives me this output

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

So naturally fancontrol doesnt work.

After this, the fan is always on. I set the pc to powersaving mode and still always has the fan on. Typing sensors in terminal gives me this output

acpitz-virtual-0
Adapter: Virtual device
temp1:        +56.0°C  (crit = +100.0°C)
temp2:        +46.0°C  (crit = +100.0°C)
temp3:        +60.0°C  (crit = +100.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +51.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +51.0°C  (high = +105.0°C, crit = +105.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:        +61.0°C

Which my radeon temperature is always around 60 (even cold boot). I go to my Windows 7 partition and the fan dies down quickly. I boot back to Ubuntu from shutdown and once the login screen comes up, the fan is on and loud (even if the laptop was cold from external temperatures). Also there is no option in bios to limit the fan speeds.

Furthermore, I have also done the steps listed on this webpage: http://javacolors.blogspot.com/2011/10/ubuntu-1110-ati-radeon-deal.html

Is there any other methods without installing the ati proprietary drivers to solve this fan solution?

share|improve this question
    
As said by Arup Chop, installing Catalyst 12.2 driver is your best choice. Also, propietary driver does good job with Gnome Shell since 11.11. –  crackout12 Mar 26 '12 at 5:54
1  
I tried from the ati website and it killed the ui (random graphic glitches everywhere) as well as screen tearing and slow down (dragging windows) feels as if it was rendering with software. –  user654628 Mar 27 '12 at 1:48
    
I just installed Catalyst 12.2 and now gnome 3 is flashing. Also the boot menu is screwed up (looks strange) –  user654628 Mar 27 '12 at 4:12
    
You need to purge any previous installs of the fglrx propietary driver, before any other fglrx install. Let me find some commands to purge the installation and I will post it as answer ;) –  crackout12 Mar 28 '12 at 21:40
add comment

5 Answers 5

up vote 3 down vote accepted

I'd struggled with this problem during two weeks. I'm using desktop and ati 5770.

Opensource 'radeon' driver has some power management feature via adjusting gpu clock, but it didn't works very well.

Here is good article about radeon and fglrx power management.

The Current State Of Radeon Power Management

This is my alias for opensource radeon power management.

# radeon gpu power management
alias profilepm='sudo bash -c "echo profile > /sys/class/drm/card0/device/power_method"'
alias auto='profilepm && sudo bash -c "echo auto > /sys/class/drm/card0/device/power_profile"'
alias low='profilepm && sudo bash -c "echo low > /sys/class/drm/card0/device/power_profile"'
alias mid='profilepm && sudo bash -c "echo mid > /sys/class/drm/card0/device/power_profile"'
alias high='profilepm && sudo bash -c "echo high > /sys/class/drm/card0/device/power_profile"'
alias dynpm='sudo bash -c "echo dynpm > /sys/class/drm/card0/device/power_method"'
alias gpu="sudo cat /sys/kernel/debug/dri/0/radeon_pm_info /sys/class/drm/card0/device/power_method"

First select default method.

  • profilepm for manual clock setting
  • dynpm for ondemand clock setting. But it just change between mid and high. Never going to low. At least to me.

If you select profilepm, select clock manually.

  • low
  • mid
  • high
  • auto

I never tried auto. But sounds like good for laptop.

Quote from X.org radeon wiki article,

"auto" selects between "mid" and "high" power states based on the whether the system is on battery power or not. The "low" power state are selected when the monitors are in the dpms off state.

Use 'gpu' command show current method and clock.

All about these settings are from here,

KMS Power Management Options

I used to 'low' in 11.10 but little bit sluggish when many firefox tabs and windows open. After jump to 12.04, I'm using unity and 'fglrx-updates' driver. It works quite well.

If you good with these settings, save them for reboot.

Install sysfsutils package then add rule to /etc/sysfs.conf file.

class/drm/card0/device/power_method = (profile or dynpm)
class/drm/card0/device/power_profile = (select between auto, low, mid, high if u choose 'profile' method)

You can remove second line If u select 'dynpm'

share|improve this answer
    
After following these steps and steps from here: wiki.ubuntu.com/X/Troubleshooting/… this by updating the open source drivers to keep the fan lower. It doesn't turn off the fan but it is a solution that would give me a usable UI (vs installing from ati's site and gives me a laggy and screen tearing mess) –  user654628 Mar 29 '12 at 2:02
add comment

If power management is your concern, then I suggest you switch to latest AMD Catalyst 12.2 which does a far better job of PM and suspend.

share|improve this answer
2  
I can't use them, it would slow down the ui so bad that it looks like it is rendering from software. Scrolling screen tears and dragging windows is slow and chunky. The fan does lower but the open source drivers are much smoother. –  user654628 Mar 27 '12 at 1:52
add comment

I found the sysfsutils-solution not to work for me (as described here). For others with the same problem this might be an alternative solution using pm-utils. I'm not sure if it is the best way to do it (I'm new to Linux) but it does all I wished for: Set the radeon power_profile to low on boot and retain that setting after suspend-resume.

Step 1: Create hook

gksudo gedit /usr/lib/pm-utils/power.d/radeon-power_profile

Step 2: Fill in the desired setting

#!/bin/sh

echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile

exit 0

Step 3: Make it executable

sudo chmod +x /usr/lib/pm-utils/power.d/radeon-power_profile

That's it :)

share|improve this answer
add comment

There is new improvment :)

Resolves stability issues found in the previous AMD Catalyst 12.11 Beta8 driver for Linux For users experiencing issues with HDMI Audio under Ubuntu 12.04, users should try installing the “dkms-hda - 0.201211291615~precise1” package from https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages and reboot; this will resolve the HDMI Audio issue found in Ubuntu 12.04

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst1211betadriver.aspx

But wait there is more they have made a new version in 2013

AMD Catalyst™ Proprietary Display Driver - Linux x86 & Linux x86_64

Stable version Amazing

Description: Automated installer and Display Drivers for Xorg/Xserver 6.9 and above (up to 1.13)

http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.42&lang=English

share|improve this answer
add comment

Before installing (or reinstalling) any AMD/ATI fglrx Catalyst Propietary Driver, you need to purge any configuration to make fglrx a clean space to work with X.Org, this is because drivers may get bugs on your computer such as slowness, inadecuate functionality, or multiple issues. Also, in order to try out this method, I suggest you to remove the scripts you made to underclock your computer from the page you said on the question. If you have any doubts about his procedure don't forget to ask.

To remove the fglrx, run these commands;

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

(Please note, if first command gives errors, just skip to second command)

If in case you haven't made the download from the ATI website, get the lastest with these commands (the fglrx from Ubuntu repositories or "Additional Drivers(Jockey)" are outdated);

To make a folder for the download and work in your home folder, although not necessarily;

cd ~/; mkdir catalyst12.2; cd catalyst12.2/

To download the lastest driver, (which as time of writing is Catalyst 12.2);

wget -O amd-driver-installer-12-2-x86.x86_64.run http://www2.ati.com/drivers/linux/amd-driver-installer-12-2-x86.x86_64.run

(Note that download will work for both 32 bit and 64 bit architectures)

Make the installer script executable;

sudo chmod +x amd-driver-installer-12-2-x86.x86_64.run

Run the installer script;

sudo sh ./amd-driver-installer-12-2-x86.x86_64.run

Now follow install with defaults, when setup is finished, open a new terminal and type;

sudo aticonfig --initial -f

When finished, make sure to reboot/restart your computer. Don't try any application before rebooting, as you may unstabilize your X.Org, so just reboot in the same terminal with;

sudo reboot now

Or do it within your graphic interface.

Make sure to tell us how it went through, good luck! ;)

share|improve this answer
    
I did this and reverted, sure the fan was not loud but it was very very laggy (the interface). Other issues (probably the graphics card) is that when plugging in my second monitor it doesnt update some of my 2nd screen (it think it has one monitor even though there are two) and a bunch of other issues. –  user654628 Mar 29 '12 at 1:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.